码迷,mamicode.com
首页 > Web开发 > 详细

HDOJ1088 Write a simple HTML Browser 【simulation】

时间:2014-05-15 04:29:39      阅读:370      评论:0      收藏:0      [点我收藏+]

标签:hdoj1088

Write a simple HTML Browser

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6917    Accepted Submission(s): 1853


Problem Description
If you ever tried to read a html document on a Macintosh, you know how hard it is if no Netscape is installed.
Now, who can forget to install a HTML browser? This is very easy because most of the times you don‘t need one on a MAC because there is a Acrobate Reader which is native to MAC. But if you ever need one, what do you do?
Your task is to write a small html-browser. It should only display the content of the input-file and knows only the html commands (tags) <br> which is a linebreak and <hr> which is a horizontal ruler. Then you should treat all tabulators, spaces and newlines as one space and display the resulting text with no more than 80 characters on a line.
 

Input
The input consists of a text you should display. This text consists of words and HTML tags separated by one or more spaces, tabulators or newlines.
A word is a sequence of letters, numbers and punctuation. For example, "abc,123" is one word, but "abc, 123" are two words, namely "abc," and "123". A word is always shorter than 81 characters and does not contain any ‘<‘ or ‘>‘. All HTML tags are either <br> or <hr>.
 

Output
You should display the the resulting text using this rules:
  . If you read a word in the input and the resulting line does not get longer than 80 chars, print it, else print it on a new line.
  . If you read a <br> in the input, start a new line.
  . If you read a <hr> in the input, start a new line unless you already are at the beginning of a line, display 80 characters of ‘-‘ and start a new line (again).
The last line is ended by a newline character.
 

Sample Input
Hallo, dies ist eine ziemlich lange Zeile, die in Html aber nicht umgebrochen wird. <br> Zwei <br> <br> produzieren zwei Newlines. Es gibt auch noch das tag <hr> was einen Trenner darstellt. Zwei <hr> <hr> produzieren zwei Horizontal Rulers. Achtung mehrere Leerzeichen irritieren Html genauso wenig wie mehrere Leerzeilen.
 

Sample Output
Hallo, dies ist eine ziemlich lange Zeile, die in Html aber nicht umgebrochen wird. Zwei produzieren zwei Newlines. Es gibt auch noch das tag -------------------------------------------------------------------------------- was einen Trenner darstellt. Zwei -------------------------------------------------------------------------------- -------------------------------------------------------------------------------- produzieren zwei Horizontal Rulers. Achtung mehrere Leerzeichen irritieren Html genauso wenig wie mehrere Leerzeilen.

注意输出结尾要添加回车。

#include <stdio.h>
#include <string.h>
char buf[82], str[82], hr[81];
int id, len;

int main(){
	//freopen("data.out", "w", stdout);
	memset(hr, ‘-‘, 80);
	while(scanf("%s", str) == 1){
		if(str[0] == ‘<‘){
			buf[id] = ‘\0‘;
			if(str[1] == ‘b‘){ puts(buf); }
			else{
				if(id){ puts(buf); }
				puts(hr);
			}
			id = 0;
			continue;
		}
		len = strlen(str);
		if(id == 0){
			memcpy(buf, str, len);
			id += len;
		}else{
			if(id + len >= 80){
				buf[id] = ‘\0‘; puts(buf);
				memcpy(buf, str, len); id = len; 
			}else{ 
				buf[id++] = ‘ ‘; memcpy(buf + id, str, len); 
				id += len; 
			}
		}
	}
	if(id){ buf[id] = ‘\0‘; printf(buf); }
	printf("\n");
	return 0;
}


HDOJ1088 Write a simple HTML Browser 【simulation】,布布扣,bubuko.com

HDOJ1088 Write a simple HTML Browser 【simulation】

标签:hdoj1088

原文地址:http://blog.csdn.net/chang_mu/article/details/25695865

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!