码迷,mamicode.com
首页 > 移动开发 > 详细

HDu 2830 Matrix Swapping II(dp)

时间:2014-10-17 23:26:50      阅读:264      评论:0      收藏:0      [点我收藏+]

标签:des   style   io   os   ar   for   sp   div   on   

Problem Description
Given an N * M matrix with each entry equal to 0 or 1. We can find some rectangles in the matrix whose entries are all 1, and we define the maximum area of such rectangle as this matrix’s goodness.

We can swap any two columns any times, and we are to make the goodness of the matrix as large as possible.
 

Input
There are several test cases in the input. The first line of each test case contains two integers N and M (1 ≤ N,M ≤ 1000). Then N lines follow, each contains M numbers (0 or 1), indicating the N * M matrix
 

Output
Output one line for each test case, indicating the maximum possible goodness.
 

Sample Input
3 4 1011 1001 0001 3 4 1010 1001 0001
 

Sample Output
4 2 Note: Huge Input, scanf() is recommended.
 

Source

题意:一列一列的移动图,问最大的1组成的面积?


思路:每一行中,对高排序,高就是a【i】,长就是i,我代码中是j,然后就可以求最优解了






</pre><pre name="code" class="cpp">#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;

#define N 1005

int h[N],a[N];
int n,m;

int cmp(int a,int b)
{
    return  a>b;
}

int main()
{
    int i,j;
    char c;

    while(~scanf("%d%d",&n,&m))
    {
        getchar();
        memset(h,0,sizeof(h));

       int ans=0;

       for(i=1;i<=n;i++)
       {
           for(j=1;j<=m;j++)
           {
               scanf("%c",&c);
               if(c=='1')
                 h[j]++;
               else
                 h[j]=0;
           }
           getchar();

           for(j=1;j<=m;j++)
             a[j]=h[j];

           sort(a+1,a+m+1,cmp);  //强调一次,是一列一列的移动

           for(j=1;j<=m;j++)
            ans=max(ans,a[j]*j);
       }
        printf("%d\n",ans);
    }
    return 0;
}


HDu 2830 Matrix Swapping II(dp)

标签:des   style   io   os   ar   for   sp   div   on   

原文地址:http://blog.csdn.net/u014737310/article/details/40192091

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!