码迷,mamicode.com
首页 > 编程语言 > 详细

Pets(匈牙利算法)

时间:2019-05-09 13:24:29      阅读:120      评论:0      收藏:0      [点我收藏+]

标签:span   The   http   src   size   ber   tac   cat   acm   

Are you interested in pets? There is a very famous pets shop in the center of the ACM city. There are totally m pets in the shop, numbered from 1 to m. One day, there are n customers in the shop, which are numbered from 1 to n. In order to sell pets to as more customers as possible, each customer is just allowed to buy at most one pet. Now, your task is to help the manager to sell as more pets as possible. Every customer would not buy the pets he/she is not interested in it, and every customer would like to buy one pet that he/she is interested in if possible.

 

技术图片

Input

There is a single integer T in the first line of the test data indicating that there are T(T≤100) test cases. In the first line of each test case, there are three numbers n, m(0≤n,m≤100) and e(0≤e≤n*m). Here, n and m represent the number of customers and the number of pets respectively.

In the following e lines of each test case, there are two integers x(1≤x≤n), y(1≤y≤m) indicating that customer x is not interested in pet y, such that x would not buy y.

Output

For each test case, print a line containing the test case number (beginning with 1) and the maximum number of pets that can be sold out.

Sample Input

1
2 2 2
1 2
2 1

Sample Output

Case 1: 2
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<queue>
#include<stack>
#include<vector>
#include<cmath>

const int maxn=1e5+5;
typedef long long ll;
using namespace std;

int n,m,k;
int link[105];  
bool visit[105],map[105][105];
bool dfs(int a)
{
    for(int i=1;i<=m;i++) 
      if(map[a][i]==0 && !visit[i])
      {
        visit[i]=1;
        if(link[i]==0 || dfs(link[i]))
        {
            link[i]=a;
            return true;
        }
      }
    return false;
}
int main()
{
    int a,b,ans;
    int T;
    cin>>T;
    int cnt=1;
    while(T--)
    {
   // memset(visit,0,sizeof(visit));
    memset(link,0,sizeof(link));
    memset(map,0,sizeof(map));
    cin>>n>>m>>k;
    ans=0;
    for(int i=1;i<=k;i++)
    {
        scanf("%d%d",&a,&b);
        map[a][b]=1;
    }
    for(int i=1;i<=n;i++) 
    {
        memset(visit,0,sizeof(visit));
        if(dfs(i))
          ans++;
    }
    printf("Case %d: %d\n",cnt++,ans);
    }
}

 

Pets(匈牙利算法)

标签:span   The   http   src   size   ber   tac   cat   acm   

原文地址:https://www.cnblogs.com/Staceyacm/p/10837764.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!