码迷,mamicode.com
首页 > 编程语言 > 详细

Arbitrage(最短路-floyd算法变形求正权)

时间:2014-10-24 09:18:36      阅读:225      评论:0      收藏:0      [点我收藏+]

标签:des   style   io   os   ar   for   strong   sp   div   

Arbitrage
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 16127   Accepted: 6780

Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No
题意:题目首先给出N中货币,然后给出了这N种货币之间的兑换的兑换率。如 USDollar 0.5 BritishPound 表示 :1 USDollar兑换成0.5 BritishPound。问在这N种货币中是否有货币可以经过若干次兑换后,兑换成原来的货币可以使货币量增加。
思路:和poj上另一道最短路的题Currency Exchange差不多。都是求正环。
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#include <map>
using namespace std;
int n,m;
double dis[50][50],rate;
map<string,int>name;//申请图的内存空间,string代表字符串,int代表数值;就是给那些钱币标号。
void floyd()
{
	int i,j,k;
	for(k=1;k<=n;k++)
	for(i=1;i<=n;i++)
		for(j=1;j<=n;j++)
        dis[i][j]=max(dis[i][j],dis[i][k]*dis[k][j]);//变形在这里
}
int main()
{
	char str[110],str1[110],str2[110];
	int cnt=1;
	int i,j;
	while(~scanf("%d",&n))
	{
	    if(n==0)
            break;
		for(i=1;i<=n;i++)
		{
			scanf("%s",str);
            name[str]=i;//标号
		}
	for(i=1;i<=n;i++)
	{
		for(j=1;j<=n;j++)
			if(i==j)
                dis[i][j]=1;
            else
                dis[i][j]=0;
	}
		scanf("%d",&m);
		for(i=0;i<m;i++)
		{
			scanf("%s%lf%s",str1,&rate,str2);
			dis[name[str1]][name[str2]]=rate;
		}
		floyd();
		int flag=0;
		for(i=1;i<=n;i++)
			if(dis[i][i]>1)//如果dis[i][i]>1证明存在正权回路
			{
				flag=1;
				break;
			}
		printf("Case %d: ",cnt++);
		if(flag)
			printf("Yes\n");
		else
			printf("No\n");
	}
}



Arbitrage(最短路-floyd算法变形求正权)

标签:des   style   io   os   ar   for   strong   sp   div   

原文地址:http://blog.csdn.net/u013486414/article/details/40411447

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!