码迷,mamicode.com
首页 > 移动开发 > 详细

HDU Catch (二分图判断奇环+并查集判断联通)

时间:2019-07-30 21:53:19      阅读:187      评论:0      收藏:0      [点我收藏+]

标签:color   set   between   start   存在   else   format   define   sse   

 

Problem Description
A thief is running away!
We can consider the city where he locates as an undirected graph in which nodes stand for crosses and edges stand for streets. The crosses are labeled from 0 to N–1.
The tricky thief starts his escaping from cross S. Each moment he moves to an adjacent cross. More exactly, assume he is at cross u at the moment t. He may appear at cross v at moment t + 1 if and only if there is a street between cross u and cross v. Notice that he may not stay at the same cross in two consecutive moment.
The cops want to know if there’s some moment at which it’s possible for the thief to appear at any cross in the city.
Input
The input contains multiple test cases:
In the first line of the input there’s an integer T which is the number of test cases. Then the description of T test cases will be given.
For any test case, the first line contains three integers N (≤ 100 000), M (≤ 500 000), and S. N is the number of crosses. M is the number of streets and S is the index of the cross where the thief starts his escaping.
For the next M lines, there will be 2 integers u and v in each line (0 ≤ u, v < N). It means there’s an undirected street between cross u and cross v.
Output
For each test case, output one line to tell if there’s a moment that it’s possible for the thief to appear at any cross. Look at the sample output for output format.
Sample Input
2
3 3 0
0 1
0 2
1 2
2 1 0
0 1
Sample Output
Case 1: YES
Case 2: NO

题意: 给一 n 个点 m 条边的无向图,再给一个起点 x,从起点出发,每个单位时间只能从一点走到相邻的点上,现在问有没有一个时刻,可以在图的任意结点上。
思路:首先,图要是不连通的,则不存在这个时刻,其次,若图是二分图也不存在完美时刻(图被分为两半,一半是奇数时刻到达,一半偶数时刻到达)
因此,只有在图连通,且非二分图的时候,才能有时刻的存在。通过并查集判断连通,再判断图是否二分图即可
 
仿照染色法进行构图 根据二分图无奇环性质解决
 
code:
//
#include<bits/stdc++.h>
using namespace std;
#define maxnn 2000110
int n,m,s;
int las[maxnn],nex[maxnn],tot,en[maxnn],col[maxnn],fla=0;
int f[maxnn];
int T;
int  gf(int v)
{
    return f[v]==v?v:f[v]=gf(f[v]);
}
void add(int a,int b)
{
    en[++tot]=b;
    nex[tot]=las[a];
    las[a]=tot;
}
void erfen(int v,int num)
{
    col[v]=num;
    if(fla==1) return ;
    for(int i=las[v];i;i=nex[i])
    {
        int y=en[i];
        if(col[y]==col[v])
        {
            fla=1;
            return ;
        }
        if(!col[y])
        {
            erfen(y,-num);
        }
     } 
     return ;
}
int main()
{
    int x,y,z;
    cin>>T;
    int tot=0;
    while(T--)
    {
        tot++;
        scanf("%d%d%d",&n,&m,&s);
        memset(las,0,sizeof(las));
        memset(col,0,sizeof(col));
        int sec=n;
        for(int i=0;i<n;i++)
            f[i]=i;
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d",&x,&y);
            add(x,y);
            add(y,x);
            if(gf(x)!=gf(y))
            {
                f[gf(x)]=gf(y);
                sec--;
            }
        }
        if(sec!=1)
        {
            printf("Case %d: ",tot);
            printf("NO\n");
            continue;
        }
        fla=0;
        erfen(s,1);
        printf("Case %d: ",tot);
        if(fla==1)
            printf("YES\n");
        else
            printf("NO\n");
    }
}

 

HDU Catch (二分图判断奇环+并查集判断联通)

标签:color   set   between   start   存在   else   format   define   sse   

原文地址:https://www.cnblogs.com/OIEREDSION/p/11272807.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!