码迷,mamicode.com
首页 > 数据库 > 详细

Linux系统如何选择MongoDB版本

时间:2019-08-06 21:23:33      阅读:147      评论:0      收藏:0      [点我收藏+]

标签:ubuntu   装包   版本   产品   mogodb   mongod   亚马逊   class   nbsp   

mogodb各个版本该怎么选:

如下图所示,我们可以看到有许多版本的安装包,那我们选择下载哪个呢?下面我会讲解一下:

技术图片

我们发现主要有6种,分别是 :

Amazon Linux(亚马逊)、

Debian Linux(Debian)、

Linux legacy(通用版)、

RHEL Linux(红帽)、

SUSE Linux(SuSE Linux AG)、

Ubuntu Linux(友帮拓、优般图、乌班图);

 

从上面的分类我们可以看出主属于5个公司的Linux以及一个Linux legacy,如何选择某个版本需要根据你将要安装的Linux属于哪个公司的产品。比我我将要安装的Linux是CenOS 7 ,该Linux是红帽公司旗下的一款Linux,所以我下载的话会选择RHEL 7 Linux 64-bit x64,同公司下的产品,我会尽量选择高版本的产品,当然不是越高越好,因为一些高版本的可能需要一些对应Linux版本,否则可能会出现不兼容的问题。
五种公司的产品我们对比自己的Linux选择,那如果我们的Linux 不属于这五个公司的,或者是这五个公司的,但是安装不成功,那我们可以选择Linux legacy这款,这款是一个通用的版本,当然对比那些按指定Linux特制的安装包,该安装包会少一些特性

 

Linux系统如何选择MongoDB版本

标签:ubuntu   装包   版本   产品   mogodb   mongod   亚马逊   class   nbsp   

原文地址:https://www.cnblogs.com/fanblogs/p/11311863.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有 京ICP备13008772号-2
迷上了代码!