码迷,mamicode.com
首页 > Web开发 > 详细

Wireless Network(并查集)

时间:2019-08-15 23:00:37      阅读:142      评论:0      收藏:0      [点我收藏+]

标签:sam   repair   cee   注意   next   color   exp   ons   class   

Problem Description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 
In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 

1. "O p" (1 <= p <= N), which means repairing computer p. 
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

The input will not exceed 300000 lines. 

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS
题意
  有一个计算机网络的所有线路都坏了,网络中有n台计算机,现在你可以做两种操作,修理(O)和检测
 
两台计算机是否连通(S),只有修理好的计算机才能连通。连通有个规则,两台计算机的距离不能超过给定的
 
最大距离D(一开始会给你n台计算机的坐标)。检测的时候输出两台计算机是否能连通
思路:

并查集的简单应用;本人用了一个结构体,记录各个电脑的状态;

按照题中所给的条件对电脑进行更新,然后进行遍历访问电脑看是否合并为一个整体集合就欧克了!

注意:算距离的时候不能算根节点到当前电脑的距离!!!

#include<iostream>
#include<cmath>
#include<cstring>
#include<cstdio>
using namespace std;
int a[1005],b[1005];
struct node
{
    double x,y;
} p[1005];
int getf(int x)
{
    if(x==b[x])
        return x;
    return b[x]=getf(b[x]);
}
void merge(int x,int y)
{
    int a,c;
    a=getf(x);
    c=getf(y);
    if(a!=c)
        b[c]=a;
}
int main()
{
    int x,y,n;
    double d;
    char c[2];
    cin>>n>>d;
    memset(a,0,sizeof(a));
    for(int i=0; i<1005; i++)
        b[i]=i;
    for(int i=1; i<=n; i++)
        cin>>p[i].x>>p[i].y;
    n=0;
    while(cin>>c)
    {
        if(c[0]==O)
        {
            cin>>x;
            for(int i=0; i<n; i++)
            {
                double tx=p[a[i]].x,ty=p[a[i]].y,ex=p[x].x,ey=p[x].y;
                double l=sqrt((tx-ex)*(tx-ex)+(ty-ey)*(ty-ey)+0.0);
                if(l<=d)
                    merge(a[i],x);
            }
            a[n++]=x;
        }
        if(c[0]==S)
        {
            cin>>x>>y;
            if(getf(x)==getf(y))
                puts("SUCCESS");
            else
                puts("FAIL");
        }
    }
    return 0;
}

 

Wireless Network(并查集)

标签:sam   repair   cee   注意   next   color   exp   ons   class   

原文地址:https://www.cnblogs.com/dwj-2019/p/11360981.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!