标签:des style http color io os ar java for
/*
中文题目 木头
中文翻译-大意 加工第一个木头要调试机器,所以要一分钟,后面的木头在长度和重量上都要大于等于前一个木头,才不要调试机器,否则要调试机器,再花费一分钟
解题思路:先将木头的长度按升序排序,后面质量发生冲突的地方就要在之后重新安排一下
解题人:lingnichong
解题时间:2014-10-25 16:33:10
解题体会:一个括号的丢失,就导致错了一大片
*/
Wooden Sticks
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12150 Accepted Submission(s): 5034
Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick.
The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:
(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l‘ and weight w‘ if l<=l‘ and w<=w‘. Otherwise, it will need 1 minute for setup.
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is
a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case,
and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
Output
The output should contain the minimum setup time in minutes, one per line.
Sample Input
3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1
Sample Output
Source
#include<stdio.h>
#include<algorithm>
using namespace std;
int temp[5005];//用来记录不同序列数的起点
struct node
{
int a,b;
}arr[5005];
int cmp(node x,node y)//排序:让长度相同的木头,质量小的在前面
{
if(x.a == y.a)
return x.b<y.b;
return x.a<y.a;
}
int main()
{
int T,N,i,j;
int time;
scanf("%d",&T);
while(T--)
{
scanf("%d",&N);
for(i=0;i<N;i++)
scanf("%d%d",&arr[i].a,&arr[i].b);
sort(arr,arr+N,cmp);
time=1;
temp[0]=arr[0].b;//先把排序后第一个点设为起点
for(i=1;i<N;i++)
{
for(j=0;j<time;j++)
{
if(arr[i].b >= temp[j])//更新一下数据,使后面质量大的数覆盖前一个质量数
{
temp[j]=arr[i].b;
break;
}
}
if(j==time)//当所有起点都不满足,就重新再安排一个起点
{
if(arr[i].b < temp[j-1])
{
temp[j]=arr[i].b;
time++;
}
}
}
printf("%d\n",time);
}
return 0;
}
HDU 1051 Wooden Sticks【贪心+排序】
标签:des style http color io os ar java for
原文地址:http://blog.csdn.net/qq_16767427/article/details/40453337