码迷,mamicode.com
首页 > 编程语言 > 详细

UOJ #572. 完全二叉排序树

时间:2019-09-05 23:05:34      阅读:371      评论:0      收藏:0      [点我收藏+]

标签:大于   限制   div   type   string   break   load   stream   algo   

【题目描述】:

二叉排序树或者是一棵空树,或者是具有下列性质的二叉树:

(1)若左子树不空,则左子树上所有结点的值均小于它的根结点的值;

(2)若右子树不空,则右子树上所有结点的值均大于它的根结点的值;

(3)左、右子树也分别为二叉排序树;

(4)没有键值相等的结点。

完全二叉树:只有最下面的两层结点度能够小于2,并且最下面一层的结点都集中在该层最左边的若干位置的二叉树。

给出N个数,且这N个数构成1至N的排列。现在需要你按顺序构建一棵二叉排序树,并按照层次遍历的方式输出它,然后判断它是否是一棵完全二叉树。

【输入描述】:

输入包含两行。第一行为一个正整数N;第二行为1至N的排列。

【输出描述】:

输出包含两行。第一行为构建出的二叉排序树的层次遍历;第二行判断是否是完全二叉树:若是输出yes,否则输出no。

【样例输入1】:

10
7 9 8 4 6 2 10 1 5 3

【样例输出1】:

7 4 9 2 6 8 10 1 3 5
yes

【样例输入2】:

5
3 4 5 2 1

【样例输出2】:

3 2 4 1 5
no

【样例说明】:

样例1:/

样例2:/

看不见图片请下载

【时间限制、数据范围及描述】:

时间:1s 空间:128M

对于100%的数据,1≤N≤20

下载

思路

先认为第一个读入的数是树的根,然后每读入一个数,依次与已经存在的节点进行比较(见build函数);

然后从第一个节点扫描,如果有是0的节点输出no;

代码:

#include<cmath>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;

const int N=1000010;

bool flag;
int tree[N];
int n,num,ma;

void build(int jd) {
	int tot=1;
	while(1) {
		if(jd>tree[tot]) {
			tot<<=1;
			tot++;
			if(!tree[tot]) {
				tree[tot]=jd;
				break;
			}
		}else{
			tot<<=1;
			//tot++;
			if(!tree[tot]) {
				tree[tot]=jd;
				break;
			}
		}
	}
	ma=max(ma,tot);
}

int main() {
	scanf("%d",&n);
	for(int i=1; i<=n; i++) {
		scanf("%d",&num);
		if(i==1) {
			tree[i]=num;
			continue;
		}
		build(num);
	}
	for(int i=1; i<=ma; i++) {
		if(!tree[i])
			flag=1;
		else
			printf("%d ",tree[i]);
	}
	printf("\n");
	if(!flag)
		printf("yes\n");
	else
		printf("no\n");
	return 0;
}

 

UOJ #572. 完全二叉排序树

标签:大于   限制   div   type   string   break   load   stream   algo   

原文地址:https://www.cnblogs.com/mysh/p/11470224.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!