码迷,mamicode.com
首页 > 编程语言 > 详细

ZOJ 3635 Cinema in Akiba[ 树状数组 ]

时间:2014-10-30 22:37:25      阅读:241      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   io   color   os   ar   for   sp   

传送门:ZOJ 3635

Cinema in Akiba

Time Limit: 3 Seconds      Memory Limit: 65536 KB

Cinema in Akiba (CIA) is a small but very popular cinema in Akihabara. Every night the cinema is full of people. The layout of CIA is very interesting, as there is only one row so that every audience can enjoy the wonderful movies without any annoyance by other audiences sitting in front of him/her.

The ticket for CIA is strange, too. There are n seats in CIA and they are numbered from 1 to n in order. Apparently, n tickets will be sold everyday. When buying a ticket, if there are k tickets left, your ticket number will be an integer i (1 ≤ ik), and you should choose the ith empty seat (not occupied by others) and sit down for the film.

On November, 11th, n geeks go to CIA to celebrate their anual festival. The ticket number of the ith geek is ai. Can you help them find out their seat numbers?

Input

The input contains multiple test cases. Process to end of file.
The first line of each case is an integer n (1 ≤ n ≤ 50000), the number of geeks as well as the number of seats in CIA. Then follows a line containing n integers a1, a2, ..., an (1 ≤ ain - i + 1), as described above. The third line is an integer m (1 ≤ m ≤ 3000), the number of queries, and the next line is m integers, q1, q2, ..., qm (1 ≤ qin), each represents the geek‘s number and you should help him find his seat.

Output

For each test case, print m integers in a line, seperated by one space. The ith integer is the seat number of the qith geek.

Sample Input

3
1 1 1
3
1 2 3
5
2 3 3 2 1
5
2 3 4 5 1

Sample Output

1 2 3
4 5 3 1 2


思路:链表模拟一排座位1-n,不断删除,然后记录座位号。用普通的链表模拟,必然TLE,so上块状链表,来弥补链表索引太慢的缺点。


代码:


#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>
#include<vector>
#include<algorithm>
#include<climits>
#define INF INT_MAX
using namespace std;

struct node{
    int num[1000];
    int sz;
    node* next;
    node(int sz){
        this->sz=sz;
        next=0;
    }
}*head=NULL;

int local[50010];
node *get_pos(int &x)
{
    node *t=head->next;
    while(t->next&&x>t->sz)
    {
        x-=t->sz;
        t=t->next;
    }
    return t;
}

void del(node *pos,int x,int ii)
{
    local[ii]=(pos->num)[x-1];
    for(int i=x;i<pos->sz;i++)
        (pos->num)[i-1]=(pos->num)[i];
    (pos->sz)--;
}

void build_bl(int n)
{
    node *ret=head;
    int sz=ceil(sqrt(n));
    int cur=0;
    for(int i=0;i<n/sz;i++)
    {
        node *t=new node(sz);
        for(int j=0;j<sz;j++)
            (t->num)[j]=(++cur);

        ret->next=t;
        ret=t;
    }

    if(n%sz)
    {
        node *t=new node(n%sz);
        for(int i=0;i<n%sz;i++)
            (t->num)[i]=(++cur);
        ret->next=t;
    }
}

void free_head()
{
    node *p=head;
    while(head->next)
    {
        head=head->next;
        free(p);
        p=head;
    }
}

int main()
{
    int n,m;
    while(scanf("%d",&n)!=EOF)
    {
        head=new node(0);
        build_bl(n);
        for(int i=1;i<=n;i++)
        {
            //printf("__hear\n");
            int x;
            scanf("%d",&x);
            node *pos=get_pos(x);
            del(pos,x,i);
        }
        free_head();
        scanf("%d",&m);
        int q;
        scanf("%d",&q);
        printf("%d",local[q]);
        for(int i=1;i<m;i++)
        {
            scanf("%d",&q);
            printf(" %d",local[q]);
        }
        printf("\n");
    }
    return 0;
}




ZOJ 3635 Cinema in Akiba[ 树状数组 ]

标签:des   style   http   io   color   os   ar   for   sp   

原文地址:http://blog.csdn.net/code_or_code/article/details/40628921

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!