码迷,mamicode.com
首页 > 移动开发 > 详细

HDU 5099 Comparison of Android versions(字符串)

时间:2014-11-02 19:41:57      阅读:238      评论:0      收藏:0      [点我收藏+]

标签:hdu   上海   

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5099


Problem Description
As an Android developer, itˇs really not easy to figure out a newer version of two kernels, because Android is updated so frequently and has many branches. Fortunately, Google identifies individual builds with a short build code, e.g. FRF85B.

The first letter is the code name of the release family, e.g. F is Froyo. The code names are ordered alphabetically. The latest code name is K (KitKat).
The second letter is a branch code that allows Google to identify the exact code branch that the build was made from, and R is by convention the primary release branch.

The next letter and two digits are a date code. The letter counts quarters, with A being Q1 2009. Therefore, F is Q2 2010. The two digits count days within the quarter, so F85 is June 24 2010.

Finally, the last letter identifies individual versions related to the same date code, sequentially starting with A; A is actually implicit and usually omitted for brevity.

Please develop a program to compare two Android build numbers.
 

Input
The first line is an integer n (1 <= n <= 2000), which indicates how many test cases need to process.

Each test case consists of a single line containing two build numbers, separated by a space character.
 

Output
For each test case, output a single line starting with ¨Case #: 〃 (# means the number of the test case). Then, output the result of release comparison as follows:

● Print "<" if the release of the first build number is lower than the second one;
● Print "=" if the release of the first build number is same as he second one;
● Print ">" if the release of the first build number is higher than the second one.

Continue to output the result of date comparison as follows:
● Print "<" if the date of the first build number is lower than the second one;
● Print "=" if the date of the first build number is same as he second one;
● Print ">" if the date of the first build number is higher than the second one.

If two builds are not in the same code branch, just compare the date code; if they are in the same code branch, compare the date code together with the individual version.
 

Sample Input
2 FRF85B EPF21B KTU84L KTU84M
 

Sample Output
Case 1: > > Case 2: = <
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:  5098 5097 5096 5095 5094 

PS:

1、比较两个字符串的第一个字母的大小;

2、如果两个字符串的第二个字母不同就比较接下来的三个字母的大小,

如果第二个字母相同就比较剩余的四个字母!


代码如下:

#include <cstdio>
#include <cstring>
const int maxn = 17;
int main()
{
    int t;
    char a[maxn], b[maxn];
    char aa[maxn], bb[maxn];
    int cas = 0;
    scanf("%d",&t);
    getchar();
    while(t--)
    {
        scanf("%s",a);
        scanf("%s",b);
        printf("Case %d: ",++cas);
        if(a[0] > b[0])
        {
            printf("> ");
        }
        else if(a[0] == b[0])
        {
            printf("= ");
        }
        else if(a[0] < b[0])
        {
            printf("< ");
        }
        if(a[1] == b[1])
        {
            aa[0] = a[2];
            aa[1] = a[3];
            aa[2] = a[4];
            aa[3] = a[5];
            aa[4] = '\0';

            bb[0] = b[2];
            bb[1] = b[3];
            bb[2] = b[4];
            bb[3] = b[5];
            bb[4] = '\0';
            if(strcmp(aa,bb) < 0)
            {
                printf("<");
            }
            else if(strcmp(aa,bb) == 0)
            {
                printf("=");
            }
            else if(strcmp(aa,bb) > 0)
            {
                printf(">");
            }
        }
        else
        {
            aa[0] = a[2];
            aa[1] = a[3];
            aa[2] = a[4];
            aa[3] = '\0';
            //aa[3] = a[5];
            bb[0] = b[2];
            bb[1] = b[3];
            bb[2] = b[4];
            bb[3] = '\0';
            //bb[3] = b[5];
            if(strcmp(aa,bb) < 0)
            {
                printf("<");
            }
            else if(strcmp(aa,bb) == 0)
            {
                printf("=");
            }
            else if(strcmp(aa,bb) > 0)
            {
                printf(">");
            }
        }
        printf("\n");
    }
    return 0;
}


HDU 5099 Comparison of Android versions(字符串)

标签:hdu   上海   

原文地址:http://blog.csdn.net/u012860063/article/details/40712625

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!