标签:http product products i++ and -- ace advance 部分
The magic shop in Mars is ofering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also ofers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product… but hey, magically, they have some coupons with negative N’s!
For example, given a set of coupons {1 2 4 -1}, and a set of product values {7 6 -2 -3} (in Mars dollars M) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M7) to get M28 back; coupon 2 to product 2 to get M12 back; and coupon 4 to product 4 to get M3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M12 to the shop.
Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.
Input Specification:
Each input file contains one test case. For each case, the first line contains the number of coupons NC,followed by a line with NC coupon integers. Then the next line contains the number of products NP,followed by a line with NP product values. Here 1<= NC,NP<=10^5, and it is guaranteed that all the numbers will not exceed 230.
Output Specification:
For each test case, simply print in a line the maximum amount of money you can get back.
Sample Input:
4
1 2 4 -1
4
7 6 -2 -3
Sample Output:
43
#include <iostream>
#include <algorithm>
using namespace std;
int main(int argc, char *argv[]) {
int NC,NP;
scanf("%d",&NC);
int cps[NC]= {0};
for(int i=0; i<NC; i++) scanf("%d",&cps[i]);
scanf("%d",&NP);
int pds[NP]= {0};
for(int i=0; i<NP; i++) scanf("%d",&pds[i]);
sort(cps,cps+NC);
sort(pds,pds+NP);
int ans=0;
for(int i=0,j=0; i<NC&&j<NP&&cps[i]<0&&pds[j]<0; i++,j++) ans+=(cps[i]*pds[j]);
for(int i=NC-1,j=NP-1; i>=0,j>=0&&cps[i]>0&&pds[j]>0; i--,j--) ans+=(cps[i]*pds[j]);
printf("%d",ans);
return 0;
}
PAT Advanced 1037 Magic Coupon (25) [贪?算法]
标签:http product products i++ and -- ace advance 部分
原文地址:https://www.cnblogs.com/houzm/p/12243719.html