码迷,mamicode.com
首页 > 编程语言 > 详细

HDU2132 An easy problem 【Java】

时间:2014-11-07 08:41:47      阅读:225      评论:0      收藏:0      [点我收藏+]

标签:hdu2132

An easy problem

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9194    Accepted Submission(s): 2491


Problem Description
We once did a lot of recursional problem . I think some of them is easy for you and some if hard for you.
Now there is a very easy problem . I think you can AC it.
  We can define sum(n) as follow:
  if i can be divided exactly by 3 sum(i) = sum(i-1) + i*i*i;else sum(i) = sum(i-1) + i;
  Is it very easy ? Please begin to program to AC it..-_-
 

Input
  The input file contains multilple cases.
  Every cases contain only ont line, every line contains a integer n (n<=100000).
  when n is a negative indicate the end of file.
 

Output
  output the result sum(n).
 

Sample Input
1 2 3 -1
 

Sample Output
1 3 30
 

Author
Wendell
 

Source
Java水过。

import java.util.Scanner;
import java.math.BigInteger;

public class Main {
    static final int maxn = 100005;
    static BigInteger[] arr = new BigInteger[maxn];

    public static void main(String[] args) {
        Scanner cin = new Scanner(System.in);
        arr[0] = BigInteger.ZERO;
        BigInteger tmp;
        for(int i = 1; i <= 100000; ++i) {
            tmp = BigInteger.valueOf(i);
            if(i % 3 == 0)
                arr[i] = arr[i-1].add(tmp.multiply(tmp).multiply(tmp));
            else arr[i] = arr[i-1].add(tmp);
        }
        int n;
        while(true) {
            n = cin.nextInt();
            if(n < 0) break;
            System.out.println(arr[n]);
        }
    }
}

C代码好像更简单些。

#include <stdio.h>

#define maxn 100005
typedef __int64 LL;

LL arr[maxn];

int main() {
    int n, i;
    for(i = 1; i <= 100000; ++i)
        if(i % 3) arr[i] = arr[i-1] + i;
        else arr[i] = arr[i-1] + (LL)i * i * i;
    while(scanf("%d", &n), n >= 0)
        printf("%I64d\n", arr[n]);
}


HDU2132 An easy problem 【Java】

标签:hdu2132

原文地址:http://blog.csdn.net/chang_mu/article/details/40867165

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!