码迷,mamicode.com
首页 > 数据库 > 详细

UVA 11584 Quick access, info and search.

时间:2014-11-08 15:16:07      阅读:150      评论:0      收藏:0      [点我收藏+]

标签:acm   uva   

Problem H: Partitioning by Palindromes

bubuko.com,布布扣

We say a sequence of characters is a palindrome if it is the same written forwards and backwards. For example, ‘racecar‘ is a palindrome, but ‘fastcar‘ is not.

partition of a sequence of characters is a list of one or more disjoint non-empty groups of consecutive characters whose concatenation yields the initial sequence. For example, (‘race‘, ‘car‘) is a partition of ‘racecar‘ into two groups.

Given a sequence of characters, we can always create a partition of these characters such that each group in the partition is a palindrome! Given this observation it is natural to ask: what is the minimum number of groups needed for a given string such that every group is a palindrome?

For example:

  • ‘racecar‘ is already a palindrome, therefore it can be partitioned into one group.
  • ‘fastcar‘ does not contain any non-trivial palindromes, so it must be partitioned as (‘f‘, ‘a‘, ‘s‘, ‘t‘, ‘c‘, ‘a‘, ‘r‘).
  • ‘aaadbccb‘ can be partitioned as (‘aaa‘, ‘d‘, ‘bccb‘).

Input begins with the number n of test cases. Each test case consists of a single line of between 1 and 1000 lowercase letters, with no whitespace within.

For each test case, output a line containing the minimum number of groups required to partition the input into groups of palindromes.

Sample Input

3
racecar
fastcar
aaadbccb

Sample Output

1
7
3

Kevin Waugh
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define maxn 1005
#define INF 10e7
using namespace std;
char s[maxn];
int dp[maxn];
int len;

bool is_Palindrome(int i,int j)
{
    for(int l=i,r=j;l<=j;l++,r--)
    {
        if(s[l]!=s[r])
            return false;
    }
    return true;
}

//dp[i]表示前i个字符所能分解最小回文串的个数
int main()
{
    int n;
    cin>>n;
    while(n--)
    {
        scanf("%s",s+1);
        int len=strlen(s+1);
        for(int i=1;i<=len;i++)
            dp[i]=INF;
            dp[0]=0;
            for(int i=1; i<=len; i++)
                for(int j=1; j<=i; j++)
                if(is_Palindrome(j,i))
                    dp[i]=min(dp[i],dp[j-1]+1);
                cout<<dp[len]<<endl;
    }
    return 0;
}

UVA 11584 Quick access, info and search.

标签:acm   uva   

原文地址:http://blog.csdn.net/dojintian/article/details/40921011

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!