码迷,mamicode.com
首页 > 编程语言 > 详细

hdu 2122(Ice_cream’s world III)(最小生成树,两种算法都可以)

时间:2014-11-13 16:37:46      阅读:260      评论:0      收藏:0      [点我收藏+]

标签:最小生成树   prime 算法   kuskal算法   

Ice_cream’s world III

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 926    Accepted Submission(s): 303


Problem Description
ice_cream’s world becomes stronger and stronger; every road is built as undirected. The queen enjoys traveling around her world; the queen’s requirement is like II problem, beautifies the roads, by which there are some ways from every city to the capital. The project’s cost should be as less as better.
 

Input
Every case have two integers N and M (N<=1000, M<=10000) meaning N cities and M roads, the cities numbered 0…N-1, following N lines, each line contain three integers S, T and C, meaning S connected with T have a road will cost C.
 

Output
If Wiskey can’t satisfy the queen’s requirement, you must be output “impossible”, otherwise, print the minimum cost in this project. After every case print one blank.
 

Sample Input
2 1 0 1 10 4 0
 

Sample Output
10 impossible
 

Author
Wiskey
 

Source

最小生成树:prime 算法,还有克鲁斯卡尔算法。
两者都可以处理。
prime代码如下:
#include<stdio.h>
#include<string.h>
int v[10010],map[10010][10010];
#define inf 0xfffffff;
int main()
{
	int n,m,i,j,a,b,c;
	while(~scanf("%d%d",&n,&m))
	{
		int sum=0;
		memset(v,0,sizeof(v));
		for(i=0;i<n;i++)//初始化 
		{
			for(j=0;j<n;j++)
			{
				map[i][j]=inf;
			}
		}
		for(i=0;i<m;i++)
		{
			scanf("%d%d%d",&a,&b,&c);
			if(c<map[a][b])//判断是否是重边,要是起点终点都相同的时候,就去权值最小的作为两个顶点间的距离即是权值 
			map[a][b]=map[b][a]=c;
		}
		v[0]=1;
		int flag;
		for(i=1;i<n;i++)
		{
			int min=inf;
			flag=-1;
			for(j=0;j<n;j++)
			{
				if(!v[j]&&map[0][j]<min)
				{
					min=map[0][j];
					flag=j;
				}
			}
			if(flag==-1)
			break;
			v[flag]=1;
			sum+=map[0][flag];
			for(j=0;j<n;j++)
			{
				if(!v[j]&&map[0][j]>map[flag][j])
				map[0][j]=map[flag][j];
			}
		}
		if(flag==-1)
		printf("impossible\n\n");
		else
		printf("%d\n\n",sum);
	}
	return 0;
}


kuskal算法代码如:
#include<stdio.h>
#include<algorithm>
using namespace std;
struct node{
	int a,b,c;
}s[10010];
int father[10010];
int find(int r)
{
	return r==father[r]?r:find(father[r]);
}
int cmp(node x,node y)
{
	return x.c<y.c;
}
int main()
{
	int n,m,i,j;
	while(~scanf("%d%d",&n,&m))
	{
		for(i=0;i<n;i++)//初始化 
		{
			father[i]=i;
		}
		for(i=0;i<m;i++)
		{
			scanf("%d%d%d",&s[i].a,&s[i].b,&s[i].c);
		}
		sort(s,s+m,cmp);//求的是最小的生成树,所以按照权值 增序排列 
		int count=0,sum=0;
		for(i=0;i<m;i++)//一共有m条边,所有循环到m 
		{
			int fa=find(s[i].a);
			int fb=find(s[i].b);
			if(fa!=fb)
			{
				father[fa]=fb;
				sum+=s[i].c;
				count++;//除了这一点都是克鲁斯卡尔算法模板 
			}
		}
		if(count!=n-1)//是否是n-1条边 即建立了一个满足条件的最小生成树 
		{
			printf("impossible\n\n");
		}
		else
		printf("%d\n\n",sum);
	}
	return 0;
} 


 

hdu 2122(Ice_cream’s world III)(最小生成树,两种算法都可以)

标签:最小生成树   prime 算法   kuskal算法   

原文地址:http://blog.csdn.net/ice_alone/article/details/41081515

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!