码迷,mamicode.com
首页 > 数据库 > 详细

Firebird Database On MacOSX

时间:2014-11-26 20:57:48      阅读:235      评论:0      收藏:0      [点我收藏+]

标签:io   ar   os   for   数据   on   div   art   cti   

Firebird Database

firebird作为一款优秀的嵌入式(之一功能),用于桌面开发最合适不过了。之前也用过SQLITE做过一些小工具,但是在安全性方面表现不佳,而且不支持存储过程等特性,经过比较最终转向firebird,整理了下常用的命令语句和SQL。

用户管理

gsec -user sysdba -password masterkey
modify SYSDBA -pw gtlions
add gtlions -pw gtlions
quit

创建数据库

isql
create database ‘gtlions.fdb‘ user ‘SYSDBA‘ password ‘gtlions‘ default character set UTF8;
create database ‘gtlions1.fdb‘ user ‘gtlions‘ password ‘G1!tlion‘ default character set GBK;
exit;

连接数据库

isql gtlions.fdb -user sysdba -password gtlions
isql gtlions.fdb -u gtlions -p ‘G1!tlion‘
isql gtlions1.fdb -u gtlions -p gtlions

安装完成后的配置,禁止启动

sudo launchctl unload /Library/LaunchDaemons/org.firebird.gds.plist
sudo launchctl unload /System/Library/LaunchAgents/com.apple.bird.plist

卸载脚本

vi script_for_remove_firebird.sh

#!/bin/sh
echo "Clean Services"
echo "Clean User"
dscl localhost -delete /Local/Default/Users/firebird
echo "Clean Group"
dscl localhost -delete /Local/Default/Groups/firebird
if [ -f "/Library/StartupItems/Firebird" ]; then
echo "Remove SuperServer StartupItem"
rm -fr /Library/StartupItems/Firebird
fi
if [ -f "/Library/LaunchDaemons/org.firebird.gds.plist" ]; then
echo "Remove Launchd"
launchctl unload /Library/LaunchDaemons/org.firebird.gds.plist
rm /Library/LaunchDaemons/org.firebird.gds.plist
fi
echo "Remove Framework"
rm -fr /Library/Frameworks/Firebird.framework
echo "Remove Receipt"
rm -fr /Library/Receipts/Firebird*.pkg

sudo launchctl unload /Library/LaunchDaemons/org.firebird.gds.plist

Firebird Database On MacOSX

标签:io   ar   os   for   数据   on   div   art   cti   

原文地址:http://blog.csdn.net/gtlions/article/details/41521503

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!