码迷,mamicode.com
首页 > 编程语言 > 详细

poj 2155 Matrix(二维树树状数组)

时间:2014-11-28 10:25:34      阅读:168      评论:0      收藏:0      [点我收藏+]

标签:poj 2155   martrix   树状数组   二维树状数组   

Matrix
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 19113   Accepted: 7193

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a ‘0‘ then change it into ‘1‘ otherwise change it into ‘0‘). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 

There is a blank line between every two continuous test cases. 

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

Source

POJ Monthly,Lou Tiancheng


题意:给你个矩阵里面开始全是0,然后给你两种指令:1:‘C x1,y1,x2,y2’就是将左上角为x1,y1,右下角为x2,y2,的这个矩阵内的数字全部翻转,0变1,1变0,;2:‘Q x1 y1‘,输出a[x1][y1]的值。

CODE:
#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

const int N = 1010;

int n, arr[N][N];

int lowbit ( int x )
{
    return x & ( -x );
}

void update ( int i, int j, int val )
{
    while ( i <= n )
    {
        int tmpj = j;
        while ( tmpj <= n )
        {
            arr[i][tmpj] += val;
            tmpj += lowbit ( tmpj );
        }
        i += lowbit ( i );
    }
}

int Sum ( int i, int j )
{
    int ans = 0;
    while ( i > 0 )
    {
        int tmpj = j;
        while ( tmpj > 0 )
        {
            ans += arr[i][tmpj];
            tmpj -= lowbit ( tmpj );
        }
        i -= lowbit ( i );
    }
    return ans;
}

int main()
{
    //freopen("input.txt","r",stdin);
    int t, q;
    scanf ( "%d", &t );
    char op[3];
    while ( t-- )
    {
        scanf ( "%d%d", &n, &q );
        memset ( arr, 0, sizeof ( arr ) );
        int x1, y1, x2, y2;
        while ( q-- )
        {
            scanf ( "%s", op );
            if ( op[0] == 'C' )
            {
                scanf ( "%d%d%d%d", &x1, &y1, &x2, &y2 );
                update ( x2 + 1, y2 + 1, 1 );
                update ( x2 + 1, y1, 1 );
                update ( x1, y2 + 1, 1 );
                update ( x1, y1, 1 );
            }
            else if ( op[0] == 'Q' )
            {
                scanf ( "%d%d", &x1, &y1 );
                printf ( "%d\n", Sum ( x1, y1 ) % 2 );
            }
        }
        if ( t )
            printf ( "\n" );
    }
    return 0;
}


poj 2155 Matrix(二维树树状数组)

标签:poj 2155   martrix   树状数组   二维树状数组   

原文地址:http://blog.csdn.net/acm_baihuzi/article/details/41555793

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!