码迷,mamicode.com
首页 > 编程语言 > 详细

HDU 2647 Reward(拓扑排序)

时间:2014-12-05 00:45:43      阅读:316      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   io   ar   color   os   sp   for   

Problem Description
Dandelion‘s uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a‘s reward should more than b‘s.Dandelion‘s unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work‘s reward will be at least 888 , because it‘s a lucky number.
 

Input
One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)
then m lines ,each line contains two integers a and b ,stands for a‘s reward should be more than b‘s.
 

Output
For every case ,print the least money dandelion ‘s uncle needs to distribute .If it‘s impossible to fulfill all the works‘ demands ,print -1.
 

Sample Input
2 1 1 2 2 2 1 2 2 1
 

Sample Output
1777 -1
 

Author
dandelion


拓扑排序。。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
typedef long long LL;
using namespace std;
#define REPF( i , a , b ) for ( int i = a ; i <= b ; ++ i )
#define REP( i , n ) for ( int i = 0 ; i < n ; ++ i )
#define CLEAR( a , x ) memset ( a , x , sizeof a )
const int maxn=10100;
int head[maxn*2],next[maxn*2],end[maxn*2];
int in[maxn],val[maxn];
int n,m,cnt,k;
void toposort()
{
   int sum=0;
   k=0;
   queue<int>q;
   REPF(i,1,n)
     if(!in[i])  q.push(i);
   while(!q.empty())
   {
       int v=q.front();
       sum+=val[v];
       q.pop();
       k++;
       for(int i=head[v];i!=-1;i=next[i])
       {
           if(--in[end[i]]==0)
           {
             q.push(end[i]);
             val[end[i]]=val[v]+1;
           }
       }
   }
   if(k==n)  printf("%d\n",sum);
   else   printf("-1\n");
}
void add(int x,int y)
{
    next[cnt]=head[x];
    end[cnt]=y;
    head[x]=cnt++;
}
int main()
{
     int x,y;
     while(~scanf("%d%d",&n,&m))
     {
         cnt=0;
         REPF(i,1,n)   val[i]=888;
         CLEAR(in,0);
         CLEAR(head,-1);
         REP(i,m)
         {
             scanf("%d%d",&x,&y);
             add(y,x);
             in[x]++;
         }
         toposort();
     }
     return 0;
}


HDU 2647 Reward(拓扑排序)

标签:des   style   blog   io   ar   color   os   sp   for   

原文地址:http://blog.csdn.net/u013582254/article/details/41734849

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!