码迷,mamicode.com
首页 > 编程语言 > 详细

HDU 1157 Who's in the Middle (快速排序 or 任意排序)

时间:2014-12-11 14:04:21      阅读:168      评论:0      收藏:0      [点我收藏+]

标签:hdu   排序   水题   

Who‘s in the Middle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9903    Accepted Submission(s): 4736


Problem Description
FJ is surveying his herd to find the most average cow. He wants to know how much milk this ‘median‘ cow gives: half of the cows give as much or more than the median; half give as much or less. 

Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.
 

Input
* Line 1: A single integer N 

* Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.
 

Output
* Line 1: A single integer that is the median milk output.
 

Sample Input
5 2 4 1 3 5
 

Sample Output
3
Hint
INPUT DETAILS: Five cows with milk outputs of 1..5 OUTPUT DETAILS: 1 and 2 are below 3; 4 and 5 are above 3.

就是奇数个数字,求中位数,排序下,即可

#include<iostream>
#include<stdio.h>
#include<string.h>
int a[10010];
using namespace std;
void Swap(int *a,int *b){
    int t=*a;
    *a=*b;
    *b=t;
}
int partition(int a[],int l,int h){
    int v = a[l];
    int i=l;
    int j=h+1;
    while(true){
        while(a[++i]<v)if(i==h)break;
        while(v<a[--j])if(j==l)break;
        if(i>=j)break;
        Swap(&a[i],&a[j]);
    }
    Swap(&a[l],&a[j]);
    return j;
}
void quick_sort(int a[],int l,int h){
    if(h<=l)return ;
    int j=partition(a,l,h);
    quick_sort(a,l,j-1);//左边
    quick_sort(a,j+1,h);//右边
}
int main(int argc, char *argv[])
{
    //freopen("1157.in","r",stdin);
    int N;
    int i;
    while(scanf("%d",&N)!=EOF)
    {
        i=0;
        for(i=0;i<N;++i)
            scanf("%d",&a[i]);
        quick_sort(a, 0, N-1);
        printf("%d\n",a[N/2]);
    }
    return 0;
}
注意事项:partition一定要有返回值!!!别糊涂了,此外,partition确定后,排前面的,和后面的即可,即j-1,j+1

HDU 1157 Who's in the Middle (快速排序 or 任意排序)

标签:hdu   排序   水题   

原文地址:http://blog.csdn.net/wdkirchhoff/article/details/41865579

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!