码迷,mamicode.com
首页 > Web开发 > 详细

HDU - 1061 - Rightmost Digit (快速幂取模!)

时间:2014-12-14 10:43:18      阅读:179      评论:0      收藏:0      [点我收藏+]

标签:快速幂取模   acm   algorithm   c++   hdu   

Rightmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 34329    Accepted Submission(s): 13091


Problem Description
Given a positive integer N, you should output the most right digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the rightmost digit of N^N.
 

Sample Input
2 3 4
 

Sample Output
7 6
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
 

Author
Ignatius.L
 


快速幂取模,不解释!


AC代码:


#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <iostream>
#include <cstdlib>
using namespace std;

int qmi(int m)
{
	int a = m%10, ans = 1;
	while(m)
	{
		if(m&1)
		ans = (ans*a)%10;
		a = (a*a)%10;
		m>>=1;
	}
	return ans%10;
}

int main()
{
	int n, t;
	scanf("%d", &t);
	while(t--)
	{
		scanf("%d", &n);
		printf("%d\n", qmi(n));
	} 
	return 0;
} 




HDU - 1061 - Rightmost Digit (快速幂取模!)

标签:快速幂取模   acm   algorithm   c++   hdu   

原文地址:http://blog.csdn.net/u014355480/article/details/41923359

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!