码迷,mamicode.com
首页 > 编程语言 > 详细

HDU - 2680 - Choose the best route (经典最短路问题dijkstra算法!!)

时间:2015-01-02 09:49:19      阅读:170      评论:0      收藏:0      [点我收藏+]

标签:hdu   acm   dijkstra   最短路   

Choose the best route

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7671    Accepted Submission(s): 2524


Problem Description
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
 

Input
There are several test cases. 
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.
 

Output
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
 

Sample Input
5 8 5 1 2 2 1 5 3 1 3 4 2 4 7 2 5 6 2 3 5 3 5 1 4 5 1 2 2 3 4 3 4 1 2 3 1 3 4 2 3 2 1 1
 

Sample Output
1 -1
 

Author
dandelion
 

Source




AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#define INF 0x7f7f7f7f
using namespace std;

const int MAX = 1005;
int n, m, s;
int map[MAX][MAX], dis[MAX], vis[MAX];

void dijk(int s)
{
	for(int i=1; i<=n; i++) dis[i] = map[s][i];
	vis[s] = 1; dis[s] = 0;
	for(int i=1; i<n; i++)
	{
		int min = INF, pos;
		for(int j = 1; j <= n; j++)
			if(!vis[j] && dis[j] < min)
				min = dis[pos = j];
		if(min == INF)  break;
		vis[pos] = 1;
		for(int j=1; j<=n; j++)
			if(!vis[j] && dis[pos] + map[pos][j] < dis[j])
				dis[j] = dis[pos] + map[pos][j];
	}
}

int main()
{
	while(scanf("%d %d %d", &n, &m, &s) != EOF)
	{
		memset(vis, 0, sizeof(vis));
		memset(map, 0x7f, sizeof(map));
		while(m--)
		{
			int x, y, w;
			scanf("%d %d %d", &x, &y, &w);
			if(w < map[y][x]) map[y][x] = w;		//注意是有向的,反方向 
		}
		dijk(s);
		int a, b, ans = INF;
		scanf("%d", &b);
		for(int i=1; i<=b; i++)
		{
			scanf("%d", &a);
			ans = min(ans, dis[a]);
		}
		if(ans != INF)printf("%d\n", ans);
		else printf("-1\n");
	}
	return 0;
}




HDU - 2680 - Choose the best route (经典最短路问题dijkstra算法!!)

标签:hdu   acm   dijkstra   最短路   

原文地址:http://blog.csdn.net/u014355480/article/details/42323367

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!