码迷,mamicode.com
首页 > 移动开发 > 详细

UVA 299- Train Swapping(冒泡排序中交换次数)

时间:2015-01-03 09:23:03      阅读:218      评论:0      收藏:0      [点我收藏+]

标签:

Train Swapping
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

技术分享


 Train Swapping 

At an old railway station, you may still encounter one of the last remaining ``train swappers‘‘. A train swapper is an employee of the railroad, whose sole job it is to rearrange the carriages of trains.

Once the carriages are arranged in the optimal order, all the train driver has to do, is drop the carriages off, one by one, at the stations for which the load is meant.

The title ``train swapper‘‘ stems from the first person who performed this task, at a station close to a railway bridge. Instead of opening up vertically, the bridge rotated around a pillar in the center of the river. After rotating the bridge 90 degrees, boats could pass left or right.

The first train swapper had discovered that the bridge could be operated with at most two carriages on it. By rotating the bridge 180 degrees, the carriages switched place, allowing him to rearrange the carriages (as a side effect, the carriages then faced the opposite direction, but train carriages can move either way, so who cares).

Now that almost all train swappers have died out, the railway company would like to automate their operation. Part of the program to be developed, is a routine which decides for a given train the least number of swaps of two adjacent carriages necessary to order the train. Your assignment is to create that routine.

Input Specification

The input contains on the first line the number of test cases (N). Each test case consists of two input lines. The first line of a test case contains an integer L, determining the length of the train ( 技术分享 ). The second line of a test case contains a permutation of the numbers 1 through L, indicating the current order of the carriages. The carriages should be ordered such that carriage 1 comes first, then 2, etc. with carriage L coming last.

Output Specification

For each test case output the sentence: ‘Optimal train swapping takes S swaps.‘ where S is an integer.

Example Input

3
3
1 3 2
4
4 3 2 1
2
2 1

Example Output

Optimal train swapping takes 1 swaps.
Optimal train swapping takes 6 swaps.
Optimal train swapping takes 1 swaps.

题意:就是简单的冒泡排序,让你求出冒泡排序过程中交换的次数

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
int main()
{
    int a[110];
    int T,n,t,i,j;
    scanf("%d",&T);
    while(T--)
    {
        int cnt=0;
        scanf("%d",&n);
        for(i=0;i<n;i++)
            scanf("%d",&a[i]);
        for(i=0;i<n;i++)
            for(j=i+1;j<n;j++)
        {
            if(a[i]>a[j])
            {
                t=a[i];
                a[i]=a[j];
                a[j]=t;
                cnt++;
            }
        }
        printf("Optimal train swapping takes %d swaps.\n",cnt);
    }
    return 0;

}


UVA 299- Train Swapping(冒泡排序中交换次数)

标签:

原文地址:http://blog.csdn.net/u013486414/article/details/42346715

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!