码迷,mamicode.com
首页 > Windows程序 > 详细

UESTC windy数位dp

时间:2015-01-03 09:28:25      阅读:255      评论:0      收藏:0      [点我收藏+]

标签:acm   数位dp   

题目链接:http://acm.uestc.edu.cn/#/problem/show/250

题目描述:

windy数

Time Limit: 3000/1000MS (Java/Others)     Memory Limit: 65535/65535KB (Java/Others)
 

windy定义了一种windy数。

不含前导零且相邻两个数字之差至少为2的正整数被称为windy数。

windy想知道,在AB之间,包括AB,总共有多少个windy数?

Input

包含两个整数,A B

满足 1AB2000000000 .

Output

Sample input and output

Sample Input Sample Output
1 10
9

Source

Windy
题意:如题所说,题意很明确了;
思路:这是我学习数位dp以来,第一道全自主思考+代码实现的题;
dp[i][j][z]:前i位数,以j结尾,z==1表示有前导为0,z==0表示前导不为0 包含windy数的个数
记忆化搜索~当然打表也行~
#include <iostream>
#include <stdio.h>
#include <string>
#include <string.h>

using namespace std;
int dp[25][25][3];
int bit[25];

int dfs(int pos,int pre,int flag,int z)
{
  if(pos==0)return 1;
  if( !flag && dp[pos][pre][z]!=-1)return dp[pos][pre][z];
  int end=flag?bit[pos]:9;
  int ans=0;
  for(int i=0;i<=end;i++)
  {
    if( z==1 || pre-i>=2 || i-pre>=2 ) ans+=dfs(pos-1,i,flag&&(i==end),z&&(i==0));
  }
  if(!flag)dp[pos][pre][z]=ans;
  return ans;
}

int cal(int x)
{
 int len=0;
 memset(bit,0,sizeof(bit));
 memset(dp,-1,sizeof(dp));
 while(x)
 {
   bit[++len]=x%10;
   x/=10;
 }
 return dfs(len,0,1,1);
}

int main()
{
  int l,r;
  while(scanf("%d%d",&l,&r)!=EOF)
  {
      int s1=cal(r);
      int s2=cal(l-1);
      printf("%d\n",s1-s2);
  }
  return 0;
}


UESTC windy数位dp

标签:acm   数位dp   

原文地址:http://blog.csdn.net/liusuangeng/article/details/42342699

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!