码迷,mamicode.com
首页 > Windows程序 > 详细

poj 2482 Stars in Your Window(线段树+扫描线+离散化)

时间:2015-01-11 14:55:59      阅读:313      评论:0      收藏:0      [点我收藏+]

标签:

Stars in Your Window
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 10433   Accepted: 2874

Description

Fleeting time does not blur my memory of you. Can it really be 4 years since I first saw you? I still remember, vividly, on the beautiful Zhuhai Campus, 4 years ago, from the moment I saw you smile, as you were walking out of the classroom and turned your head back, with the soft sunset glow shining on your rosy cheek, I knew, I knew that I was already drunk on you. Then, after several months’ observation and prying, your grace and your wisdom, your attitude to life and your aspiration for future were all strongly impressed on my memory. You were the glamorous and sunny girl whom I always dream of to share the rest of my life with. Alas, actually you were far beyond my wildest dreams and I had no idea about how to bridge that gulf between you and me. So I schemed nothing but to wait, to wait for an appropriate opportunity. Till now — the arrival of graduation, I realize I am such an idiot that one should create the opportunity and seize it instead of just waiting. 

These days, having parted with friends, roommates and classmates one after another, I still cannot believe the fact that after waving hands, these familiar faces will soon vanish from our life and become no more than a memory. I will move out from school tomorrow. And you are planning to fly far far away, to pursue your future and fulfill your dreams. Perhaps we will not meet each other any more if without fate and luck. So tonight, I was wandering around your dormitory building hoping to meet you there by chance. But contradictorily, your appearance must quicken my heartbeat and my clumsy tongue might be not able to belch out a word. I cannot remember how many times I have passed your dormitory building both in Zhuhai and Guangzhou, and each time aspired to see you appear in the balcony or your silhouette that cast on the window. I cannot remember how many times this idea comes to my mind: call her out to have dinner or at least a conversation. But each time, thinking of your excellence and my commonness, the predominance of timidity over courage drove me leave silently. 

Graduation, means the end of life in university, the end of these glorious, romantic years. Your lovely smile which is my original incentive to work hard and this unrequited love will be both sealed as a memory in the deep of my heart and my mind. Graduation, also means a start of new life, a footprint on the way to bright prospect. I truly hope you will be happy everyday abroad and everything goes well. Meanwhile, I will try to get out from puerility and become more sophisticated. To pursue my own love and happiness here in reality will be my ideal I never desert. 

Farewell, my princess! 

If someday, somewhere, we have a chance to gather, even as gray-haired man and woman, at that time, I hope we can be good friends to share this memory proudly to relight the youthful and joyful emotions. If this chance never comes, I wish I were the stars in the sky and twinkling in your window, to bless you far away, as friends, to accompany you every night, sharing the sweet dreams or going through the nightmares together. 
技术分享

Here comes the problem: Assume the sky is a flat plane. All the stars lie on it with a location (x, y). for each star, there is a grade ranging from 1 to 100, representing its brightness, where 100 is the brightest and 1 is the weakest. The window is a rectangle whose edges are parallel to the x-axis or y-axis. Your task is to tell where I should put the window in order to maximize the sum of the brightness of the stars within the window. Note, the stars which are right on the edge of the window does not count. The window can be translated but rotation is not allowed. 

Input

There are several test cases in the input. The first line of each case contains 3 integers: n, W, H, indicating the number of stars, the horizontal length and the vertical height of the rectangle-shaped window. Then n lines follow, with 3 integers each: x, y, c, telling the location (x, y) and the brightness of each star. No two stars are on the same point. 

There are at least 1 and at most 10000 stars in the sky. 1<=W,H<=1000000, 0<=x,y<2^31. 

Output

For each test case, output the maximum brightness in a single line.

Sample Input

3 5 4
1 2 3
2 3 2
6 3 1
3 5 4
1 2 3
2 3 2
5 3 1

Sample Output

5
6




题意:在一个平面内有N个星星,每个星星都在一个亮度值,用一个W*H的矩形去围这

些星星,(边上的不算) 求能得到的最大亮度值。

思路:以x从小到大排序,y值离散化,投影到y轴上,那么对于每个星星的纵坐标,y,y+h-1就

是每个星星可以影响到的矩形 然后x,x+w就是一个进入事件和一个出去事件,其所带的值互

为相反数. node[1].sum 保存当前的最大值 当所有的矩形都遍历一遍 取其中的最大值就是ans。


#include <iostream>
#include <cstdio>
#include <algorithm>
#define LL long long
using namespace std;
const int maxn=20010;

struct tree
{
    int l,r;
    LL val,add;
}a[maxn*4];
struct node
{
    LL x,y1,y2,val;
    void fun(LL _x,LL _y1,LL _y2,LL _val)
    {
        x=_x,y1=_y1,y2=_y2;
        val=_val;
    }
}b[maxn];

LL n,W,H,Y[maxn];
int cnt;

bool cmp(node p,node q)
{
     return p.x<q.x;
}

void build(int l,int r,int k)
{
    a[k].l=l,a[k].r=r;
    a[k].val=a[k].add=0;
    if(l==r)  return ;
    int mid=(l+r)/2;
    build(l,mid,2*k);
    build(mid+1,r,2*k+1);
}

void pushback(int k)
{
    a[2*k].val+=a[k].add;
    a[2*k].add+=a[k].add;
    a[2*k+1].val+=a[k].add;
    a[2*k+1].add+=a[k].add;
    a[k].add=0;
}

void insert(LL l,LL r,LL val,int k)
{
    if(Y[a[k].l]==l && Y[a[k].r]==r)
    {
         a[k].val+=val;
         a[k].add+=val;
    }
    else
    {
        pushback(k);
        int mid=(a[k].l+a[k].r)/2;
        if(Y[mid]>=r)      insert(l,r,val,2*k);
        else if(Y[mid]<l)  insert(l,r,val,2*k+1);
        else
        {
            insert(l,Y[mid],val,2*k);
            insert(Y[mid+1],r,val,2*k+1);
        }
        a[k].val=max(a[2*k].val,a[2*k+1].val);
    }
}

void input()
{
    LL x,y,c;
    cnt=0;
    for(int i=0;i<n;i++)
    {
         scanf("%lld %lld %lld",&x,&y,&c);
         Y[cnt]=y;
         b[cnt++].fun(x,y,y+H-1,c);
         Y[cnt]=y+H-1;
         b[cnt++].fun(x+W,y,y+H-1,-c);
    }
    sort(Y,Y+cnt);
    sort(b,b+cnt,cmp);
}

void solve()
{
    int coun=unique(Y,Y+cnt)-Y;
    build(0,coun-1,1);

    LL ans=0;
    for(int i=0;i<cnt;i++)
    {
        insert(b[i].y1,b[i].y2,b[i].val,1);//cout<<"!!!"<<endl;
        ans=max(ans,a[1].val);
    }
    printf("%d\n",ans);
}

int main()
{
    while(scanf("%lld %lld %lld",&n,&W,&H)!=EOF)
    {
         input();
         solve();
    }
    return 0;
}




poj 2482 Stars in Your Window(线段树+扫描线+离散化)

标签:

原文地址:http://blog.csdn.net/u012596172/article/details/42610617

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!