码迷,mamicode.com
首页 > 移动开发 > 详细

HDU 5119 Happy Matt Friends(简单二维dp)

时间:2015-01-17 20:55:27      阅读:211      评论:0      收藏:0      [点我收藏+]

标签:

题意不再说了,就是一个二维的dp,维持取最大值是多少。

Happy Matt Friends

Time Limit: 6000/6000 MS (Java/Others)    Memory Limit: 510000/510000 K (Java/Others)
Total Submission(s): 608    Accepted Submission(s): 229


Problem Description
Matt has N friends. They are playing a game together.

Each of Matt’s friends has a magic number. In the game, Matt selects some (could be zero) of his friends. If the xor (exclusive-or) sum of the selected friends’magic numbers is no less than M , Matt wins.

Matt wants to know the number of ways to win.
 

Input
The first line contains only one integer T , which indicates the number of test cases.

For each test case, the first line contains two integers N, M (1 ≤ N ≤ 40, 0 ≤ M ≤ 106).

In the second line, there are N integers ki (0 ≤ ki ≤ 106), indicating the i-th friend’s magic number.
 

Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1) and y indicates the number of ways where Matt can win.
 

Sample Input
2 3 2 1 2 3 3 3 1 2 3
 

Sample Output
Case #1: 4 Case #2: 2
Hint
In the ?rst sample, Matt can win by selecting: friend with number 1 and friend with number 2. The xor sum is 3. friend with number 1 and friend with number 3. The xor sum is 2. friend with number 2. The xor sum is 2. friend with number 3. The xor sum is 3. Hence, the answer is 4.
 

Source
 
#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <stack>
#include <ctime>
#include <map>
#include <set>
#define eps 1e-9
///#define M 1000100
///#define LL __int64
#define LL long long
///#define INF 0x7ffffff
#define INF 0x3f3f3f3f
#define PI 3.1415926535898
#define zero(x) ((fabs(x)<eps)?0:x)
#define mod 1000000007

using namespace std;

const int maxn = 1<<20;


inline int read()
{
    char ch;
    bool flag = false;
    int a = 0;
    while(!((((ch = getchar()) >= '0') && (ch <= '9')) || (ch == '-')));
    if(ch != '-')
    {
        a *= 10;
        a += ch - '0';
    }
    else
    {
        flag = true;
    }
    while(((ch = getchar()) >= '0') && (ch <= '9'))
    {
        a *= 10;
        a += ch - '0';
    }
    if(flag)
    {
        a = -a;
    }
    return a;
}
void write(int a)
{
    if(a < 0)
    {
        putchar('-');
        a = -a;
    }
    if(a >= 10)
    {
        write(a / 10);
    }
    putchar(a % 10 + '0');
}

LL dp[45][maxn+100];

int num[45];

int main()
{
    int T;
    cin >>T;
    int Case = 1;
    while(T--)
    {
        int n, m;
        n = read();
        m = read();
        for(int i = 1; i <= n; i++) num[i] = read();
        memset(dp, 0, sizeof(dp));
        dp[0][0] = 1LL;
        for(int i = 1; i <= n; i++)
        {
            for(int j = 0; j <= maxn-5; j++)
            {
                dp[i][j] = max(dp[i][j], dp[i-1][j]+dp[i-1][j^num[i]]);
            }
        }
        LL sum = 0;
        for(int i = m; i <= maxn-5; i++) sum += dp[n][i];
        printf("Case #%d: ", Case++);
        cout<<sum<<endl;
    }
}


HDU 5119 Happy Matt Friends(简单二维dp)

标签:

原文地址:http://blog.csdn.net/xu12110501127/article/details/42809073

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!