码迷,mamicode.com
首页 > 编程语言 > 详细

(离散化+树状数组求逆序数) poj 2299

时间:2015-01-28 14:21:53      阅读:110      评论:0      收藏:0      [点我收藏+]

标签:

Ultra-QuickSort
Time Limit: 7000MS   Memory Limit: 65536K
Total Submissions: 44390   Accepted: 16149

Description

技术分享In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<cstdlib>
#include<algorithm>
using namespace std;
#define N 1000000
int n,reflect[N],c[N];
long long ans;
struct node
{
      int val;
      int pos;
}a[N];
bool cmp(node a,node b)
{
      return a.val<b.val;
}
int lowbit(int x)
{
      return x&(-x);
}
int sum(int x)
{
      int sum=0;
      while(x>0)
      {
          sum+=c[x];
          x=x-lowbit(x);
      }
      return sum;
}
void add(int pos,int x)
{
      while(pos<N)
      {
            c[pos]+=x;
            pos+=lowbit(pos);
      }
}
int main()
{
      while(scanf("%d",&n)!=EOF)
      {
            if(n==0)
                  break;
            memset(reflect,0,sizeof(reflect));
            memset(c,0,sizeof(c));
            ans=0;
            for(int i=1;i<=n;i++)
            {
                  scanf("%d",&a[i].val);
                  a[i].pos=i;
            }
            sort(a+1,a+1+n,cmp);
            for(int i=1;i<=n;i++)
                  reflect[a[i].pos]=i;
            for(int i=1;i<=n;i++)
            {
                  add(reflect[i],1);
                  ans+=i-sum(reflect[i]);
            }
            printf("%I64d\n",ans);
      }
      return 0;
}

  

(离散化+树状数组求逆序数) poj 2299

标签:

原文地址:http://www.cnblogs.com/a972290869/p/4255524.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!