码迷,mamicode.com
首页 > 编程语言 > 详细

(树状数组) poj 3067

时间:2015-01-28 19:43:22      阅读:236      评论:0      收藏:0      [点我收藏+]

标签:

Japan
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 21769   Accepted: 5885

Description

Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.

Input

The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the East coast and second one is the number of the city of the West coast.

Output

For each test case write one line on the standard output: 
Test case (case number): (number of crossings)

Sample Input

1
3 4 4
1 4
2 3
3 2
3 1

Sample Output

Test case 1: 5

排个序,转化成逆序数
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cstdlib>
#include<cmath>
#include<algorithm>
using namespace std;
#define N 2010
int tt,n,m,k,c[N];
struct node
{
      int x,y,pos;
}e[N*N];
bool cmp(node a,node b)
{
      if(a.x!=b.x) return a.x<b.x;
      return a.y<b.y;
};
int lowbit(int x)
{
      return x&(-x);
}
void update(int pos,int m)
{
      while(pos<N)
      {
            c[pos]+=m;
            pos+=lowbit(pos);
      }
}
int sum(int x)
{
      int sum=0;
      while(x>0)
      {
            sum+=c[x];
            x-=lowbit(x);
      }
      return sum;
}
int main()
{
      int cas=1;
      scanf("%d",&tt);
      while(tt--)
      {
            long long  ans=0;
            memset(c,0,sizeof(c));
            scanf("%d%d%d",&n,&m,&k);
            for(int i=1;i<=k;i++)
                  scanf("%d%d",&e[i].x,&e[i].y);
            sort(e+1,e+1+k,cmp);
            for(int i=1;i<=k;i++)
            {
                  update(e[i].y,1);
                  ans+=i-sum(e[i].y);
            }
            printf("Test case %d: %I64d\n",cas,ans);
            cas++;
      }
      return 0;
}

  

(树状数组) poj 3067

标签:

原文地址:http://www.cnblogs.com/a972290869/p/4256726.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!