码迷,mamicode.com
首页 > Web开发 > 详细

HDOJ 1045 Fire Net

时间:2015-01-31 21:55:43      阅读:201      评论:0      收藏:0      [点我收藏+]

标签:dfs

题目来源:http://acm.hdu.edu.cn/showproblem.php?pid=1045


Fire Net

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6917    Accepted Submission(s): 3911


Problem Description
Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall. 

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening. 

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets. 

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through. 

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways. 

技术分享

Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration. 
 

Input
The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a ‘.‘ indicating an open space and an uppercase ‘X‘ indicating a wall. There are no spaces in the input file. 
 

Output
For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.
 

Sample Input
4 .X.. .... XX.. .... 2 XX .X 3 .X. X.X .X. 3 ... .XX .XX 4 .... .... .... .... 0
 

Sample Output
5 1 5 2 4
 

Source
 

题意:略。

题解:十天前写了下这题,一直WA~~ 刚刚重写,一次A了。总结起来,还是自己一些细节没有处理好。我是直接深搜,把每个点都遍历一遍。图很小,不会超时。据说还有用二分图匹配的——还没有接触,不会,以后再看看。

AC代码:

#include<iostream>
#include<string>
#define maxn 5
using namespace std;
string chess[maxn],init[maxn];
int n,res;
int dir[4][2]={
    {0,1},{0,-1},{1,0},{-1,0}
};
void Copy(string x[],string y[]){
    for(int i=0;i<n;i++)
        x[i]=y[i];
}
void SetFlag(int x,int y){
    chess[x][y]='#';
    for(int i=0;i<4;i++){
        int dx=x+dir[i][0],dy=y+dir[i][1];
        while(dx>=0&&dx<n&&dy>=0&&dy<n&&init[dx][dy]=='.'){
            chess[dx][dy]='X';
            dx+=dir[i][0]; dy+=dir[i][1];
        }
    }
}
void dfs(int s,int cnt){
    if(s>=n)return ;
    if(res<cnt)res=cnt;
    bool flag=true;
    for(int i=0;i<n;i++){
        if(s>=0&&s<n&&chess[s][i]=='.'){
            flag=false;
            string temp[maxn];
            Copy(temp,chess);
            SetFlag(s,i);
            if(i==n-1)dfs(s+1,cnt+1);
            else dfs(s,cnt+1);
            Copy(chess,temp);
        }
    }
    if(s<n-1&&flag)dfs(s+1,cnt);
}
int main()
{
    while(cin>>n&&n){
        res=0;
        for(int i=0;i<n;i++) cin>>init[i];
        for(int i=0;i<n;i++)
        for(int j=0;j<n;j++){
            if(init[i][j]=='.'){
                Copy(chess,init);
                SetFlag(i,j);
                dfs(0,1);
            }
        }
        cout<<res<<endl;
    }
    return 0;
}



HDOJ 1045 Fire Net

标签:dfs

原文地址:http://blog.csdn.net/mummyding/article/details/43345675

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!