码迷,mamicode.com
首页 > Web开发 > 详细

Rightmost Digit

时间:2015-02-03 12:53:52      阅读:127      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 35848    Accepted Submission(s): 13581


Problem Description
Given a positive integer N, you should output the most right digit of N^N.
 

 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

 

Output
For each test case, you should output the rightmost digit of N^N.
 

 

Sample Input
2 3 4
 

 

Sample Output
7 6
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
 
 
思路:一道简单的快速幂,刚开始看错了题目,一直没有思路。
若把a^b%c看做b个a相乘并分布求余,b太大显然会超时,快速幂的原理是:降低 b 的次数,把a变大(涉及求余,对a不影响);
技术分享
#include<cstdio>
int powermod(int a,int b,int c)
{
    int ans=1;
    a=a%c;
    if(a==0)
    return 0;
    while(b>0)
    {
        if(b%2==1)
        ans=ans*a%c;
        b/=2;
        a=a*a%c;
    }
    return ans;
}
int main()
{
    int T;
    int n;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        printf("%d\n",powermod(n,n,10));
    }
    return 0;
}
View Code

 

Rightmost Digit

标签:

原文地址:http://www.cnblogs.com/orchidzjl/p/4269477.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!