码迷,mamicode.com
首页 > Web开发 > 详细

HDU 1072 Nightmare

时间:2015-02-06 21:50:51      阅读:194      评论:0      收藏:0      [点我收藏+]

标签:搜索   printf   math.h   acm算法   c   


Problem Description
Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius‘ start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can‘t get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can‘t use the equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius‘ start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius‘ target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.
 

Output
For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.
 

Sample Input
3 3 3 2 1 1 1 1 0 1 1 3 4 8 2 1 1 0 1 1 1 0 1 0 4 1 1 0 4 1 1 0 0 0 0 0 0 1 1 1 1 4 1 1 1 3 5 8 1 2 1 1 1 1 1 4 1 0 0 0 1 0 0 1 1 4 1 0 1 1 0 1 1 0 0 0 0 3 0 1 1 1 4 1 1 1 1 1
 

Sample Output
4 -1 13
 

Author
Ignatius.L

 

就算是英语渣也不影响读题。扫一遍案例,扫一遍关键词。

大概了解了题意

还是一副地图,0,1,2,3,4,构成的。炸弹在六分钟之后时候爆炸。

0是墙不能走,1可以走,2是起点,3是终点,4是重置炸弹时间的地方。经过4就说明离炸弹爆炸的时间又到了6分钟。

上下左右四个方向,每走一步一分钟。

问的是能否逃出去。(爆炸之前)

了解以上之后就是一个简单的广搜和一些剪枝就好了。

上代码

 

 

#include <stdio.h>
#include <algorithm>
#include <queue>
using namespace std;
int dir[4][2]={{0,1},{0,-1},{1,0},{-1,0}};
#define inf 0x6fffff
int map[10][10];
int vis[10][10];
int n,m,x2,y2;
struct node
{
	int x,y,time,step;
}
;
void bfs(int x,int y)
{
	int i;
	node st,ed;
	queue<node>q;
	st.x=x;
	st.y=y;
	st.time=6;  //初始时间
	st.step=0;  //初始步数
	q.push(st);
	while(!q.empty())
	{
		st=q.front();
		q.pop();
		if(st.x==x2 &&st.y==y2)   //到达3这个位置
		{
			printf("%d\n",st.step);
			return ;
		}
		for(i=0;i<4;i++)
		{
			ed.x=st.x+dir[i][0];
			ed.y=st.y+dir[i][1];
			ed.time=st.time-1;  //时间-1.
			ed.step=st.step+1;// 步数加一
			if(ed.x>=0 &&ed.y>=0 &&ed.x<n&&ed.y<m &&map[ed.x][ed.y]!=0 &&ed.time>0 &&vis[ed.x][ed.y]<st.time)//最后一个剪枝关键,可以代表下一步能走,并且炸弹还没爆炸。(时间剪枝)因为有可能经过4的地方又返回,如案例三。
			{
				if(map[ed.x][ed.y]==4)//经过4,重置时间
					ed.time=6;  
				vis[ed.x][ed.y]=ed.time;
				q.push(ed);
			}
		}
	}
	printf("-1\n");
}
int main()
{
	int t,i,j;
    scanf("%d",&t);
	int x1,y1;
	while(t--)
	{ 
		int i,k;
		scanf("%d%d",&n,&m);
		for(i=0;i<n;i++)
			for(j=0;j<m;j++)
			{
				scanf("%d",&map[i][j]);
				if(map[i][j]==2)
				{
					x1=i;y1=j;//记录
				}
				if(map[i][j]==3)
				{
                    x2=i,y2=j;//记录
				}
			}
			memset(vis,0,sizeof(vis));
			bfs(x1,y1);//跑一遍BFS即可
	}
	return 0;
}


 

HDU 1072 Nightmare

标签:搜索   printf   math.h   acm算法   c   

原文地址:http://blog.csdn.net/sky_miange/article/details/43574013

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!