码迷,mamicode.com
首页 > 编程语言 > 详细

POJ 2185 Milking Grid (二维KMP next数组)

时间:2015-02-12 00:45:16      阅读:166      评论:0      收藏:0      [点我收藏+]

标签:poj   kmp   

Milking Grid
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 6665   Accepted: 2824

Description

Every morning when they are milked, the Farmer John‘s cows form a rectangular grid that is R (1 <= R <= 10,000) rows by C (1 <= C <= 75) columns. As we all know, Farmer John is quite the expert on cow behavior, and is currently writing a book about feeding behavior in cows. He notices that if each cow is labeled with an uppercase letter indicating its breed, the two-dimensional pattern formed by his cows during milking sometimes seems to be made from smaller repeating rectangular patterns.

Help FJ find the rectangular unit of smallest area that can be repetitively tiled to make up the entire milking grid. Note that the dimensions of the small rectangular unit do not necessarily need to divide evenly the dimensions of the entire milking grid, as indicated in the sample input below.

Input

* Line 1: Two space-separated integers: R and C

* Lines 2..R+1: The grid that the cows form, with an uppercase letter denoting each cow‘s breed. Each of the R input lines has C characters with no space or other intervening character.

Output

* Line 1: The area of the smallest unit from which the grid is formed

Sample Input

2 5
ABABA
ABABA

Sample Output

2

Hint

The entire milking grid can be constructed from repetitions of the pattern ‘AB‘.

Source

USACO 2003 Fall

题目链接:http://poj.org/problem?id=2185

题目大意:给你一个r行c列的字符矩阵,令其一个子矩阵,使得这个子矩阵无限复制成的大矩阵包含原矩阵,现求这个子矩阵的最小尺寸

题目分析:1.把每行字符串看作一个整体对行求next数组
                  2.将矩阵转置
                  3.进行操作1,注意这里的行是原来的列,列是原来的行,相当于求原来列的next数组
                  4.求出len-next[len]即最小不重复子串的长度作为子矩形的边长

#include <cstdio>
#include <cstring>
char s[10005][80], rs[80][10005];
int R[10005], C[10005];
int r, c;

void get_nextR() 
{  
    R[0] = -1;
    int j = -1, i = 0;
    while(i < r)
    {
        if(j == -1 || strcmp(s[i], s[j]) == 0)
        {
            i++;
            j++;
            R[i] = j;
        }
        else
            j = R[j];
    }  
}  

void get_nextC() 
{  
    C[0] = -1;
    int j = -1, i = 0;
    while(i < c)
    {
        if(j == -1 || strcmp(rs[i], rs[j]) == 0)
        {
            i++;
            j++;
            C[i] = j;
        }
        else
            j = C[j];
    }  
} 

int main()
{
    while(scanf("%d %d", &r, &c) != EOF)
    {
        for(int i = 0; i < r; i++) 
            scanf("%s", s[i]);
        get_nextR();
        for(int i = 0; i < r; i++)
            for(int j = 0; j < c; j++)
                rs[j][i] = s[i][j];
        get_nextC();
        printf("%d\n", (r - R[r]) * (c - C[c]));
    }
}



POJ 2185 Milking Grid (二维KMP next数组)

标签:poj   kmp   

原文地址:http://blog.csdn.net/tc_to_top/article/details/43746885

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!