标签:
Caocao‘s Bridges
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1752 Accepted Submission(s): 642
Problem Description
Caocao was defeated by Zhuge Liang and Zhou Yu in the battle of Chibi. But he wouldn‘t give up. Caocao‘s army still was not good at water battles, so he came up with another idea. He built many islands in the Changjiang river, and
based on those islands, Caocao‘s army could easily attack Zhou Yu‘s troop. Caocao also built bridges connecting islands. If all islands were connected by bridges, Caocao‘s army could be deployed very conveniently among those islands. Zhou Yu couldn‘t stand
with that, so he wanted to destroy some Caocao‘s bridges so one or more islands would be seperated from other islands. But Zhou Yu had only one bomb which was left by Zhuge Liang, so he could only destroy one bridge. Zhou Yu must send someone carrying the
bomb to destroy the bridge. There might be guards on bridges. The soldier number of the bombing team couldn‘t be less than the guard number of a bridge, or the mission would fail. Please figure out as least how many soldiers Zhou Yu have to sent to complete
the island seperating mission.
Input
There are no more than 12 test cases.
In each test case:
The first line contains two integers, N and M, meaning that there are N islands and M bridges. All the islands are numbered from 1 to N. ( 2 <= N <= 1000, 0 < M <= N2 )
Next M lines describes M bridges. Each line contains three integers U,V and W, meaning that there is a bridge connecting island U and island V, and there are W guards on that bridge. ( U ≠ V and 0 <= W <= 10,000 )
The input ends with N = 0 and M = 0.
Output
For each test case, print the minimum soldier number Zhou Yu had to send to complete the mission. If Zhou Yu couldn‘t succeed any way, print -1 instead.
Sample Input
3 3
1 2 7
2 3 4
3 1 4
3 2
1 2 7
2 3 4
0 0
Sample Output
Source
Recommend
liuyiding | We have carefully selected several similar problems for you:
5173 5172 5171 5170 5169
ac代码
#include<stdio.h>
#include<string.h>
#include<queue>
#include<string>
#include<iostream>
#define INF 0xfffffff
#define max(a,b) (a>b?a:b)
#define min(a,b) (a<b?a:b)
using namespace std;
int low[100100],dfn[100100],vis[100100],head[100100];
int n,m,cnt,time,sum,ans;
struct s
{
int u,v,w,next;
}edge[1010*1010*2];
void init()
{
memset(head,-1,sizeof(head));
cnt=time=sum=0;
memset(low,-1,sizeof(low));
memset(dfn,-1,sizeof(dfn));
}
void add(int u,int v,int w)
{
edge[cnt].u=u;
edge[cnt].v=v;
edge[cnt].w=w;
edge[cnt].next=head[u];
head[u]=cnt++;
}
void dfs(int u)
{
if(vis[u])
return ;
vis[u]=1;
sum++;
for(int i=head[u];i!=-1;i=edge[i].next)
{
int v=edge[i].v;
dfs(v);
}
}
void tarjan(int u,int pre)
{
low[u]=dfn[u]=time++;
int flag=1;
for(int i=head[u];i!=-1;i=edge[i].next)
{
int v=edge[i].v;
if(flag&&v==pre)//去重边
{
flag=0;
continue;
}
/* if(i==(pre^1))
continue;*/
if(dfn[v]==-1)
{
tarjan(v,u);
low[u]=min(low[u],low[v]);
if(dfn[u]<low[v])
{
if(ans>edge[i].w)
{
ans=edge[i].w;
}
}
}
else
low[u]=min(low[u],dfn[v]);
}
}
int main()
{
//int n,m;
while(scanf("%d%d",&n,&m)!=EOF,n||m)
{
int i;
init();
for(i=0;i<m;i++)
{
int a,b,c;
scanf("%d%d%d",&a,&b,&c);
add(a,b,c);
add(b,a,c);
}
memset(vis,0,sizeof(vis));
dfs(1);
if(sum<n)
{
printf("0\n");
continue;
}
ans=INF;
tarjan(1,-1);
if(ans==INF)
printf("-1\n");
else
{
if(!ans)ans=1;
printf("%d\n",ans);
}
}
}
HDOJ 题目4738 Caocao's Bridges(双联通,求桥)
标签:
原文地址:http://blog.csdn.net/yu_ch_sh/article/details/43739643