码迷,mamicode.com
首页 > 编程语言 > 详细

hdu 4081 Qin Shi Huang's National Road System 次小生成树 算法

时间:2015-02-23 09:42:05      阅读:254      评论:0      收藏:0      [点我收藏+]

标签:hdu4081   qin shi huangs natio   次小生成树   prim   

Qin Shi Huang‘s National Road System

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4180    Accepted Submission(s): 1450


Problem Description
During the Warring States Period of ancient China(476 BC to 221 BC), there were seven kingdoms in China ---- they were Qi, Chu, Yan, Han, Zhao, Wei and Qin. Ying Zheng was the king of the kingdom Qin. Through 9 years of wars, he finally conquered all six other kingdoms and became the first emperor of a unified China in 221 BC. That was Qin dynasty ---- the first imperial dynasty of China(not to be confused with the Qing Dynasty, the last dynasty of China). So Ying Zheng named himself "Qin Shi Huang" because "Shi Huang" means "the first emperor" in Chinese.
技术分享

Qin Shi Huang undertook gigantic projects, including the first version of the Great Wall of China, the now famous city-sized mausoleum guarded by a life-sized Terracotta Army, and a massive national road system. There is a story about the road system:
There were n cities in China and Qin Shi Huang wanted them all be connected by n-1 roads, in order that he could go to every city from the capital city Xianyang.
Although Qin Shi Huang was a tyrant, he wanted the total length of all roads to be minimum,so that the road system may not cost too many people‘s life. A daoshi (some kind of monk) named Xu Fu told Qin Shi Huang that he could build a road by magic and that magic road would cost no money and no labor. But Xu Fu could only build ONE magic road for Qin Shi Huang. So Qin Shi Huang had to decide where to build the magic road. Qin Shi Huang wanted the total length of all none magic roads to be as small as possible, but Xu Fu wanted the magic road to benefit as many people as possible ---- So Qin Shi Huang decided that the value of A/B (the ratio of A to B) must be the maximum, which A is the total population of the two cites connected by the magic road, and B is the total length of none magic roads.
Would you help Qin Shi Huang?
A city can be considered as a point, and a road can be considered as a line segment connecting two points.
 

Input
The first line contains an integer t meaning that there are t test cases(t <= 10).
For each test case:
The first line is an integer n meaning that there are n cities(2 < n <= 1000).
Then n lines follow. Each line contains three integers X, Y and P ( 0 <= X, Y <= 1000, 0 < P < 100000). (X, Y) is the coordinate of a city and P is the population of that city.
It is guaranteed that each city has a distinct location.
 

Output
For each test case, print a line indicating the above mentioned maximum ratio A/B. The result should be rounded to 2 digits after decimal point.
 

Sample Input
2 4 1 1 20 1 2 30 200 2 80 200 1 100 3 1 1 20 1 2 30 2 2 40
 

Sample Output
65.00 70.00
转载博客请申明原地址:http://blog.csdn.net/lionel_d

 我这辈子做的最傻逼的事情就是把数组类型定义错了,导致我wrong了10次。。。max数组本应该定义成double,结果傻逼了,定义成了int。。真想撞墙!!!
不了解次小生成树的话,看这篇博客http://www.cnblogs.com/hxsyl/p/3290832.html。说的非常详细。
刚开始做的时候,一点思路都没有,,网上搜明明是最小生成树的题,,怎么用最小生成树就是很难解决呢!百度了发现,,尼玛是次小生成树。。还有第K小生成树!!!,累觉不爱
下面看我的代码吧:
#include <stdio.h>
#include <math.h>
#include <string.h>
#include <stdlib.h>
#define MAX 1010
const double INF = 100000000.0 ;

struct Point{
	int x,y;
};
double graph[MAX][MAX] , lowCost[MAX] , max[MAX][MAX];//max[i][j]表示i到j所有路径中最大的一个路径权值 ,
int pop[MAX] , closest[MAX] ;//pop:保存每个城市的人数,closest保存最短路径的顶点 
bool used[MAX][MAX] ;	//used[i][j]标记 i到j这条路在不在最小生成树中。 
double prim(int n)
{
	bool visited[MAX] ;
	memset(visited,false,sizeof(visited)) ;
	memset(max,0,sizeof(max)) ;
	memset(used,false,sizeof(used)) ;
	for(int i = 1 ; i <= n ; ++i)
	{
		closest[i] = 1 ;
		lowCost[i] = graph[1][i] ;
	}
	visited[1] = true ;
	double sum = 0.0 ;
	for(int i = 0 ; i < n-1 ; ++i)
	{
		double min = INF ;
		int index = -1 ;
		for(int j = 1 ; j <= n ; ++j)
		{
			if(!visited[j] && lowCost[j]<min)
			{
				min = lowCost[j];
				index = j ;
			}
		}
		if(index == -1)
		{
			break ;
		}
		visited[index] = true ;
		sum += lowCost[index] ;
		used[index][closest[index]] = used[closest[index]][index]  = true ;
		for(int j = 1 ; j <= n ; ++j)
		{
			if(visited[j] && index != j)
			{
				max[index][j] = max[j][index] = max[j][closest[index]]>lowCost[index] ? max[j][closest[index]]:lowCost[index] ;               
			}
			if(!visited[j] && lowCost[j]>graph[index][j])
			{
				lowCost[j] = graph[index][j] ;
				closest[j] = index ;
			}
		}
	}
	return sum;
}
double dis(const Point &a , const Point &b)
{
	double x = (a.x-b.x)*1.0 , y = (a.y-b.y)*1.0 ;
	return sqrt(x*x+y*y) ;
}
int main()
{
	int t ;
	Point p[MAX] ;
	scanf("%d",&t);
	while(t--)
	{
		int n;
		scanf("%d",&n);
		for(int i = 1 ; i <= n ; ++i)
		{
			scanf("%d%d%d",&p[i].x,&p[i].y,&pop[i]) ;
		}
		for(int i = 1 ; i <= n ; ++i)
		{
			graph[i][i] = 0.0 ;
			for(int j = 1 ; j < i ; ++j)
			{
				graph[i][j] = graph[j][i] = dis(p[i],p[j]) ;
			}
		}
		double sum = prim(n) , ans = -1;
		for(int i = 1 ; i <= n ; ++i)
		{
			for(int j = 1 ; j <= n ; ++j)
			{
				if(i != j)
				{
					if(used[i][j])
					{
						double r = (pop[i]+pop[j])*1.0/(sum-graph[i][j]) ;
						ans = ans>r?ans:r ;
					}
					else
					{
						double r = (pop[i]+pop[j])*1.0/(sum-max[i][j]) ;
						ans = ans>r?ans:r ;
					}
				}
				
			}
		}
		printf("%.2lf\n",ans) ;
	}
	return 0 ;
}

与君共勉

hdu 4081 Qin Shi Huang's National Road System 次小生成树 算法

标签:hdu4081   qin shi huangs natio   次小生成树   prim   

原文地址:http://blog.csdn.net/lionel_d/article/details/43909595

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!