码迷,mamicode.com
首页 > 编程语言 > 详细

hdu 1102 Constructing Roads 最小生成树Prim算法AC 水~~~

时间:2015-02-23 15:31:07      阅读:231      评论:0      收藏:0      [点我收藏+]

标签:hdu1102   constructing roads   最小生成树   prim   

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15230    Accepted Submission(s): 5826


Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
 

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
 

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.
 

Sample Input
3 0 990 692 990 0 179 692 179 0 1 1 2
 

Sample Output
179
 

Source
 
只要把已经建好的路的权值设置为0就可以了。
水题,没什么好说的
代码:
#include <stdio.h>
#include <string.h>
#define INF 100000000
#define MAX 110

int graph[MAX][MAX] ;

int prim(int n)
{
	int lowCost[MAX],closest[MAX];
	bool visited[MAX];
	memset(visited,false,sizeof(visited)) ;
	for(int i = 1 ; i <= n ; ++i)
	{
		lowCost[i] = graph[1][i] ;
		closest[i] = 1 ;
	}
	visited[1] = true ;
	int sum = 0 ;
	for(int i = 0 ; i < n-1 ; ++i)
	{
		int min = INF , index = -1 ;
		for(int j = 1 ; j <= n ; ++j)
		{
			if(!visited[j] && min>lowCost[j])
			{
				index = j ;
				min = lowCost[j] ;
			}
		}
		if(index == -1)
		{
			break ;
		}
		sum += lowCost[index] ;
		visited[index] = true ;
		for(int j = 1 ; j <= n ; ++j)
		{
			if(!visited[j] && lowCost[j]>graph[index][j])
			{
				lowCost[j] = graph[index][j] ;
				closest[j] = index ;
			}
		}
	}
	return sum ;
}

int main()
{
	int n ;
	while(~scanf("%d",&n))
	{
		for(int i = 1 ; i <= n ; ++i)
		{
			for(int j = 1 ; j <= n ; ++j)
			{
				int w ;
				scanf("%d",&w) ;
				graph[i][j] = w ;
			}
		}
		int q ;
		scanf("%d",&q);
		for(int i = 0 ; i < q ; ++i)
		{
			int x , y ;
			scanf("%d%d",&x,&y);
			graph[x][y] = graph[y][x] = 0 ;
		}
		int sum = prim(n) ;
		printf("%d\n",sum) ;
	}
	return 0 ;
}

与君共勉

hdu 1102 Constructing Roads 最小生成树Prim算法AC 水~~~

标签:hdu1102   constructing roads   最小生成树   prim   

原文地址:http://blog.csdn.net/lionel_d/article/details/43916375

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!