码迷,mamicode.com
首页 > Windows程序 > 详细

Winter-1-B Sum 解题报告及测试数据

时间:2015-02-23 16:37:02      阅读:198      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit:500MS     

Memory Limit:32768KB

Description

?Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.

Input

The input will consist of a series of integers n, one integer per line.

Output

?For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.

Sample Input

1

100

Sample Output

1

5050 

以下是代码:

1
2
3
4
5
6
7
8
9
10
#include <cstdio>
using namespace std;
int main(){
    int n,sum;
    while(scanf("%d",&n)!=EOF){
        sum=0;
        for(int i=1;i<=n;i++)sum+=i;
        printf("%d\n\n",sum);
    }
}

Winter-1-B Sum 解题报告及测试数据

标签:

原文地址:http://www.cnblogs.com/gzdaijie/p/4298085.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!