码迷,mamicode.com
首页 > Windows程序 > 详细

Winter-1-C A + B II 解题报告及测试数据

时间:2015-02-24 00:45:39      阅读:344      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit:1000MS 

Memory Limit:32768KB

Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2

1 2

112233445566778899 998877665544332211

Sample Output

Case 1:

1 + 2 = 3

 

Case 2:

112233445566778899 + 998877665544332211 = 1111111111111111110 

以下是代码:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
char a[1000],b[1000];
int c[1100],n;
void cal(char a[],char b[],int r)
{
    int i = strlen(a),j = strlen(b);
    int k=0,t;
    i--;j--;
    memset(c,0,sizeof(c));
    while(i>=0 || j >=0){
        if(i>=0 && j>=0)t=a[i]+b[j]+c[k]-‘0‘-‘0‘;
        else if (i<0)t=b[j]+c[k]-‘0‘;
        else t=a[i]+c[k]-‘0‘;
        if(t>=10){
            c[k++]=t%10;c[k]+=1;
        }else c[k++]=t;
        i--;j--;
    }
    while(c[k]==0)k--;
    printf("Case %d:\n%s + %s = ",r,a,b);
    for(i=k;i>=0;i--)printf("%d",c[i]);
    printf("\n");
    if(r!=n)printf("\n");
}
int main(){
    int len1,len2;
    cin >> n;
    for(int i=0;i<n;i++){
        scanf("%s%s",a,b);
        cal(a,b,i+1);
    }
}

Winter-1-C A + B II 解题报告及测试数据

标签:

原文地址:http://www.cnblogs.com/gzdaijie/p/4298088.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!