码迷,mamicode.com
首页 > 编程语言 > 详细

NYOJ 179 LK's problem (排序模拟)

时间:2015-02-24 13:52:25      阅读:210      评论:0      收藏:0      [点我收藏+]

标签:排序 模拟

链接:click here~~

题意:

描述
LK has a question.Coule you help her?
It is the beginning of the day at a bank, and a crowd  of clients is already waiting for the entrance door to  open. 
Once the bank opens, no more clients arrive, and  tellerCount tellers begin serving the clients. A  
teller takes serviceTime minutes to serve each client.  clientArrivals specifies how long each client has  already been waiting at the moment when the bank door  opens. Your program should determine the best way to arrange the clients into tellerCount queues, so that  the waiting time of the client who waits longest is minimized. The waiting time of a client is the sum of  the time the client waited outside before the bank opened, the time the client waited in a queue once the  bank opened until the service began, and the service time of the client. Return the minimum waiting time for the client who waits the longest.
输入
The input will consist of several test cases. For each test case, one integer N (1<= N <= 100) is given in the first line. Second line contains N integers telling us the time each client had waited.Third line contains tow integers , teller‘s count and service time per client need. The input is terminated by a single line with N = 0.
输出
For each test of the input, print the answer.
样例输入
2
1 2
1 10
1
10 
50 50
0

样例输出

21
60
题意银行开门之前,一些人已经在门口等着办理业务。一个人等待的时间=开门前等待时间+开门后排队时间+办理业务所用时间。每个人办理业务所用时间相同,且看门后没有新增的人。问如何安排这些人的次序,能够使得等待时间最长的那个人等待的时间最短。求等待时间最长的那个人等待的时间的最小值。

       每组数据先输入一个N,代表有N个人,第二行有N个数,代表每个人在银行开门前的等待时间,第三行有二个数,分别代表银行服务人员的个数和每个人办理业务所用的时间(每个人所用时间相同).输出等待时间最长的那个人等待的时间的最小值。

思路先对开门前等待时间排序后,求出每一个人所用的时间(开门前等待时间长的先办理)然后再对每个人所用时间排序,输出最大的那个时间

代码:

 
/*
先对开门前等待时间排序后,求出每一个人所用的时间(开门前等待时间长的先办理)
然后再对每个人所用时间排序,输出最大的那个时间
*/
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;
#define Max(a,b) {a>b?a:b}
int Time[110],dp[110];
int main()
{
    int n,m,i,j,a,b;
    while(cin>>n && n!=0)
    {
        for(i=0; i<n; i++)
            cin>>Time[i];
        cin>>a>>b;
        sort(Time,Time+n);
        for(j=0,i=n-1; i>=0; i=i-a,j++)
            dp[j]=Time[i]+b*(j+1);
        sort(dp,dp+j);
        cout<<dp[j-1]<<endl;
    }
    return 0;
}

When you want to give up, think of why you persist until now !

NYOJ 179 LK's problem (排序模拟)

标签:排序 模拟

原文地址:http://blog.csdn.net/u013050857/article/details/43924905

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!