码迷,mamicode.com
首页 > Windows程序 > 详细

Winter-2-STL-A Argus 解题报告及测试数据

时间:2015-02-24 23:20:24      阅读:197      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit:2000MS     Memory Limit:65536KB

Description

A data stream is a real-time, continuous, ordered sequence of items. Some examples include sensor data, Internet traffic, financial tickers, on-line auctions, and transaction logs such as Web usage logs and telephone call records. Likewise, queries over streams run continuously over a period of time and incrementally return new results as new data arrives. For example, a temperature detection system of a factory warehouse may run queries like the following.

Query-1: Every five minutes, retrieve the maximum temperature over the past five minutes. Query-2: Return the average temperature measured on each floor over the past 10 minutes.

We have developed a Data Stream Management System called Argus, which processes the queries over the data streams. Users can register queries to the Argus. Argus will keep the queries running over the changing data and return the results to the corresponding user with the desired frequency.

For the Argus, we use the following instruction to register a query:

Register Q_numPeriod

Q_num (0 < Q_num <= 3000) is query ID-number, and Period (0 < Period <= 3000) is the interval between two consecutive returns of the result. After Period seconds of register, the result will be returned for the first time, and after that, the result will be returned everyPeriod seconds.

Here we have several different queries registered in Argus at once. It is confirmed that all the queries have different Q_num. Your task is to tell the first K queries to return the results. If two or more queries are to return the results at the same time, they will return the results one by one in the ascending order of Q_num.

Input

The first part of the input are the register instructions to Argus, one instruction per line. You can assume the number of the instructions will not exceed 1000, and all these instructions are executed at the same time. This part is ended with a line of "#"

The second part is your task. This part contains only one line, which is one positive integer K (<= 10000).

Output

You should output the Q_num of the first K queries to return the results, one number per line.

Sample Input

Register 2004 200 Register 2005 300 # 5

SampleOutput

2004 2005 2004 2004 2005

 

题解:这道题其实就是一个优先队列问题,用Node.now代表应出队的时间,pe代表周期,那么无非就是以下两点:

  1. 应出队时间小的先出队。应同时出队的,ID小的先出,那么重载<运算符即可。

  2. ?每个节点出队之后再次应出队时间应加上周期,再次入队即可。            

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
#include <iostream>
#include <cstdio>
#include <queue>
#include <string>
using namespace std;
struct Node{
    int ID,pe,now;//pe代表周期,now代表应出队时间 
}t;
bool operator < (Node t1,Node t2){
        //优先队列,出队顺序,时间小的先出,时间一致,ID小的先出
    return t1.now>t2.now || (t1.now==t2.now && t1.ID>t2.ID);
}
int main(){
    //freopen("1.in","r",stdin);
    char str[100];
    int K;
    priority_queue<Node>q;
    while(scanf("%s",str)!=EOF && str[0]!=‘#‘){
        scanf("%d%d",&t.ID,&t.pe);
        t.now = t.pe;
        q.push(t);
    }
    scanf("%d",&K);
    while(K--){
        t = q.top();q.pop();
        printf("%d\n",t.ID);
        t.now += t.pe;//每次出队,将now+pe后入队
        q.push(t);
    }
}

Winter-2-STL-A Argus 解题报告及测试数据

标签:

原文地址:http://www.cnblogs.com/gzdaijie/p/4298732.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!