码迷,mamicode.com
首页 > 编程语言 > 详细

Spring-1-I 233 Matrix(HDU 5015)解题报告及测试数据

时间:2015-03-04 01:03:12      阅读:255      评论:0      收藏:0      [点我收藏+]

标签:

233 Matrix

Time Limit:5000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

In our daily life we often use 233 to express our feelings. Actually, we may say 2333, 23333, or 233333 ... in the same meaning. And here is the question: Suppose we have a matrix called 233 matrix. In the first line, it would be 233, 2333, 23333... (it means a 0,1 = 233,a 0,2 = 2333,a 0,3 = 23333...) Besides, in 233 matrix, we got a i,j = a i-1,j +a i,j-1( i,j ≠ 0). Now you have known a 1,0,a 2,0,...,a n,0, could you tell me a n,m in the 233 matrix?

 

Input

There are multiple test cases. Please process till EOF.

For each case, the first line contains two postive integers n,m(n ≤ 10,m ≤ 10 9). The second line contains n integers, a 1,0,a 2,0,...,a n,0(0 ≤ a i,0 < 2 31).

 

Output

For each case, output a n,m mod 10000007.

 

Sample Input

1 1

1

2 2

0 0

3 7

23 47 16

 

Sample Output

234

2799

72937

Hint

技术分享

 

题解:

  1. 数字范围很大,必须用long long 整型,不然会WA。

  2. 构造矩阵时需要注意233的增长2333=233*10+3。一般情况下,递推的矩阵都可以用使用矩阵快速幂来解决。   

  3. 求快速幂的时候,需要注意当前幂指数为奇数的时候的处理。    

以下是代码:
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#include <cctype>
#include <sstream>
#include <queue>
#include <stack>
#include <stack>
#include <map>
using namespace std;
 
#define F(i,s,e) for(int i = s;i<e;i++)
#define FA(i,s,e) for(int i=s;i>e;i--)
#define ss(x) scanf("%d",&x)
#define s64(x) scanf("%I64d",&x)
#define write() freopen("1.in","r",stdin)
#define W(x) while(x)
typedef long long LL;
 
int aa[15];
int N;
const int Mod = 10000007;
struct Matrix{
    LL m[15][15];
    Matrix(){
        memset(m,0,sizeof(m));
    }
};
 
void init(Matrix&a,int n){//构造初始矩阵
    N = n+2;
    F(i,0,N)F(j,0,N)a.m[i][j]=0;
    F(i,0,n)FA(j,n-1,i-1)a.m[i][j]=1;
    F(i,0,n)a.m[n][i]=1;
    a.m[n][n]=10;
    a.m[n+1][n]=3;
    a.m[n+1][n+1]=1;
}
Matrix mul(Matrix a,Matrix b){//矩阵乘法
    Matrix c;
    F(i,0,N)
    F(j,0,N)
    F(k,0,N)
    c.m[i][j]=(c.m[i][j]+a.m[i][k]*b.m[k][j]) % Mod;
    return c;
}
Matrix power_m(Matrix a,int m){//矩阵快速幂
    Matrix b;
    F(i,0,N)b.m[i][i]=1;
    W(m){
        if(m%2)b = mul(a,b);//如果是奇数,则先乘出
        a = mul(a,a);
        m = m/2;
    }
    return b;
}
int main(){
    //write();
    int n,m;
    LL ans;
    Matrix a,b;
    W(ss(n)!=EOF){
        ss(m);
        F(i,0,n)ss(aa[i]);
        aa[n]=233;aa[n+1]=1;
        ans =0;
        init(a,n);
        b = power_m(a,m);  
        F(i,0,N)ans=(ans+aa[i]*b.m[i][n-1])%Mod;//计算右下角的值
        printf("%I64d\n",ans);
    }  
}

Spring-1-I 233 Matrix(HDU 5015)解题报告及测试数据

标签:

原文地址:http://www.cnblogs.com/gzdaijie/p/4312241.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!