码迷,mamicode.com
首页 > 移动开发 > 详细

POJ3321---Apple Tree(树状数组)

时间:2015-03-05 16:56:29      阅读:162      评论:0      收藏:0      [点我收藏+]

标签:树状数组

Description

There is an apple tree outside of kaka’s house. Every autumn, a lot of apples will grow in the tree. Kaka likes apple very much, so he has been carefully nurturing the big apple tree.

The tree has N forks which are connected by branches. Kaka numbers the forks by 1 to N and the root is always numbered by 1. Apples will grow on the forks and two apple won’t grow on the same fork. kaka wants to know how many apples are there in a sub-tree, for his study of the produce ability of the apple tree.

The trouble is that a new apple may grow on an empty fork some time and kaka may pick an apple from the tree for his dessert. Can you help kaka?

Input

The first line contains an integer N (N ≤ 100,000) , which is the number of the forks in the tree.
The following N - 1 lines each contain two integers u and v, which means fork u and fork v are connected by a branch.
The next line contains an integer M (M ≤ 100,000).
The following M lines each contain a message which is either
“C x” which means the existence of the apple on fork x has been changed. i.e. if there is an apple on the fork, then Kaka pick it; otherwise a new apple has grown on the empty fork.
or
“Q x” which means an inquiry for the number of apples in the sub-tree above the fork x, including the apple (if exists) on the fork x
Note the tree is full of apples at the beginning

Output
For every inquiry, output the correspond answer per line.

Sample Input

3
1 2
1 3
3
Q 1
C 2
Q 1

Sample Output

3
2

Source
POJ Monthly–2007.08.05, Huang, Jinsong

dfs改时间戳+树状数组

/*************************************************************************
    > File Name: poj3321.cpp
    > Author: ALex
    > Mail: zchao1995@gmail.com 
    > Created Time: 2015年03月05日 星期四 16时17分37秒
 ************************************************************************/

#include <map>
#include <set>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;

const double pi = acos(-1);
const int inf = 0x3f3f3f3f;
const double eps = 1e-15;
typedef long long LL;
typedef pair <int, int> PLL;

const int N = 100100;
int tree[N];
int l[N];
int r[N];
int head[N];
int tot;
struct node
{
    int next;
    int to;
}edge[N << 1];

void addedge (int from, int to)
{
    edge[tot].to = to;
    edge[tot].next = head[from];
    head[from] = tot++;
}

int lowbit (int x)
{
    return x & (-x);
}

void add (int x, int val)
{
    for (int i = x; i <= N; i += lowbit (i))
    {
        tree[i] += val;
    }
}

int sum (int x)
{
    int ans = 0;
    for (int i = x; i; i -= lowbit (i))
    {
        ans += tree[i];
    }
    return ans;
}

void dfs (int u, int &cnt, int fa)
{
    l[u] = ++cnt;
    for (int i = head[u]; ~i; i = edge[i].next)
    {
        int v = edge[i].to;
        if (v == fa)
        {
            continue;
        }
        dfs (v, cnt, u);
    }
    r[u] = cnt;
}

int main ()
{
    int n;
    while (~scanf("%d", &n))
    {
        int u, v;
        memset (tree, 0, sizeof(tree));
        memset (head, -1, sizeof(head));
        tot = 0;
        for (int i = 1; i <= n - 1; ++i)
        {
            scanf("%d%d", &u, &v);
            addedge (u, v);
            addedge (v, u);
        }
        int cnt = 0;
        dfs (1, cnt, -1);
        for (int i = 1; i <= n; ++i)
        {
            add (l[i], 1);
        }
        int m;
        char str[3];
        scanf("%d", &m);
        while (m--)
        {
            scanf("%s%d", str, &u);
            if (str[0] == ‘Q‘)
            {
                printf("%d\n", sum (r[u]) - sum(l[u] - 1));
            }   
            else
            {
                int sta = sum (l[u]) - sum (l[u] - 1);
                if (sta)
                {
                    add (l[u], -1);
                }
                else
                {
                    add (l[u], 1);
                }
            }
        }
    }
    return 0;
}

POJ3321---Apple Tree(树状数组)

标签:树状数组

原文地址:http://blog.csdn.net/guard_mine/article/details/44084673

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!