码迷,mamicode.com
首页 > 编程语言 > 详细

hdu 4296 Buildings 贪心算法 今日首A 详细解析 ,有些数据类型最好用long long

时间:2015-03-05 22:24:55      阅读:265      评论:0      收藏:0      [点我收藏+]

标签:hdu4296   buildings   贪心   

Buildings

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2278    Accepted Submission(s): 870


Problem Description
  Have you ever heard the story of Blue.Mary, the great civil engineer? Unlike Mr. Wolowitz, Dr. Blue.Mary has accomplished many great projects, one of which is the Guanghua Building.
  The public opinion is that Guanghua Building is nothing more than one of hundreds of modern skyscrapers recently built in Shanghai, and sadly, they are all wrong. Blue.Mary the great civil engineer had try a completely new evolutionary building method in project of Guanghua Building. That is, to build all the floors at first, then stack them up forming a complete building.
  Believe it or not, he did it (in secret manner). Now you are face the same problem Blue.Mary once stuck in: Place floors in a good way.
  Each floor has its own weight wi and strength si. When floors are stacked up, each floor has PDV(Potential Damage Value) equal to (Σwj)-si, where (Σwj) stands for sum of weight of all floors above.
  Blue.Mary, the great civil engineer, would like to minimize PDV of the whole building, denoted as the largest PDV of all floors.
  Now, it’s up to you to calculate this value.
 

Input
  There’re several test cases.
  In each test case, in the first line is a single integer N (1 <= N <= 105) denoting the number of building’s floors. The following N lines specify the floors. Each of them contains two integers wi and si (0 <= wi, si <= 100000) separated by single spaces.
  Please process until EOF (End Of File).
 

Output
  For each test case, your program should output a single integer in a single line - the minimal PDV of the whole building.
  If no floor would be damaged in a optimal configuration (that is, minimal PDV is non-positive) you should output 0.
 

Sample Input
3 10 6 2 3 5 4 2 2 2 2 2 3 10 3 2 5 3 3
 

Sample Output
1 0 2
 
这题算是简单的贪心,首先分析题目意思,就是有N块板,其中一块板的PDV = 在它上面的所有板重量-这个板的强度。然后求出这些板的PDV的最大值,问你怎么使这个最大值最小。

分析: 我们可以把公式写下来,pdv[i]=sum(w[i+1]->w[n])-s[i] ,这个式子等价于pdv[i]=sum(w[i]->w[n])-w[i]-s[i] ; 若使pdv最小,则即使需要w[i]+s[i]要达到最大 ,那好了,我们只需要按对w[i]+s[i]排序就可以,然后再求出最大的PDV。复杂度O(n*logn+n) ;n*logn是排序复杂度,我用的是STL里的sort排序。
还有一点就是有些数据类型需要是long long ,至少我的程序需要。
代码:
#include <cstdio>
#include <cstring>
#include <climits>
#include <algorithm>
#define MAX 100100
using namespace std ;
typedef long long ll ;

struct Floor{
	int w , s ;
}f[MAX];

bool cmp(const Floor &a , const Floor &b)
{
	return a.w+a.s>b.w+b.s ;
}

int main()
{
	int n ;
	while(~scanf("%d",&n))
	{
		ll sum = 0 ;
		for(int i = 0 ; i < n ; ++i)
		{
			scanf("%d%d",&f[i].w,&f[i].s) ;
			sum += f[i].w ;
		}
		sort(f,f+n,cmp) ;
		ll pdv = LLONG_MIN ;
		for(int i = 0 ; i < n ; ++i)
		{
			sum -= f[i].w ;
			if(sum-f[i].s>pdv)
			{
				pdv = sum-f[i].s ;
			}
		}
		if(pdv<=0)
		{
			puts("0") ;
		}
		else
		{
			printf("%I64d\n",pdv) ;
		}
	}
	return 0 ;
}
与君共勉

hdu 4296 Buildings 贪心算法 今日首A 详细解析 ,有些数据类型最好用long long

标签:hdu4296   buildings   贪心   

原文地址:http://blog.csdn.net/lionel_d/article/details/44086815

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!