码迷,mamicode.com
首页 > 编程语言 > 详细

匈牙利算法模板 hdu 1068 题意不清。。。。(数据范围太过随意。。)

时间:2015-03-07 17:11:20      阅读:131      评论:0      收藏:0      [点我收藏+]

标签:

Girls and Boys

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8104    Accepted Submission(s): 3711


Problem Description
the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.
 

Sample Input
7 0: (3) 4 5 6 1: (2) 4 6 2: (0) 3: (0) 4: (2) 0 1 5: (1) 0 6: (2) 0 1 3 0: (2) 1 2 1: (1) 0 2: (1) 0
 

Sample Output
5 2
 

Source

题意就个人来看不是太明确,就不再叙述题意。
考察知识点:二分图最大独立集=顶点数-最大匹配数。
不过此题尚有一些未清楚。。。
如下:
/*****************************************************************************
	考察知识点:匈牙利算法模板,二分图最大独立集=顶点数-最大匹配数 
	题意不好理解是关键。。。。 
	这道题的疑问之处在于题意(求最大匹配数 还是 所有的人组成了多少
	的组合,有关系的并为一组 ?),
	另外一点是数据的范围,有人说最大到500,到底为何? 
*****************************************************************************/
#include<stdio.h>
#include<string.h>
#define inf 500
int used[inf],girl[inf];
int line[inf][inf];
int n,m;
int find(int x)
{
	int j;
	for(j=0;j<n;++j)
	{
		if(!used[j]&&line[x][j])
		{
			used[j]=1;
			if(!girl[j]||find(girl[j]))
			{
				girl[j]=x;
				return 1;
			}
		}
	}
	return 0;
}
int main()
{
	int a,b;
	while(~scanf("%d",&n))
	{
		memset(used,0,sizeof(used));
		memset(line,0,sizeof(line));
		memset(girl,0,sizeof(girl));
		for(int i=0;i<n;++i)
		{
			scanf("%d: (%d)",&a,&m);
			while(m--)
			{
				scanf("%d",&b);
				line[a][b]=1;
			}
		}
		int count=0;
		for(int i=0;i<n;++i)
		{
			memset(used,0,sizeof(used));
			if(find(i))
			count++;
		}
		printf("%d\n",n-count/2);
	}
	return 0;
} 


匈牙利算法模板 hdu 1068 题意不清。。。。(数据范围太过随意。。)

标签:

原文地址:http://blog.csdn.net/ice_alone/article/details/44117561

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!