码迷,mamicode.com
首页 > 编程语言 > 详细

POJ 1459 Power Network (网络流最大流基础 多源点多汇点 Edmonds_Karp算法)

时间:2015-03-07 18:45:55      阅读:169      评论:0      收藏:0      [点我收藏+]

标签:poj   网络流最大流   edmonds_karp算法   


Power Network
Time Limit: 2000MS   Memory Limit: 32768K
Total Submissions: 24056   Accepted: 12564

Description

A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= pmax(u) of power, may consume an amount 0 <= c(u) <= min(s(u),cmax(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= lmax(u,v) of power delivered by u to v. Let Con=Σuc(u) be the power consumed in the net. The problem is to compute the maximum value of Con.
技术分享

An example is in figure 1. The label x/y of power station u shows that p(u)=x and pmax(u)=y. The label x/y of consumer u shows that c(u)=x and cmax(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and lmax(u,v)=y. The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6.

Input

There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of lmax(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of pmax(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of cmax(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct.

Output

For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.

Sample Input

2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
         (3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
         (0)5 (1)2 (3)2 (4)1 (5)4

Sample Output

15
6

Hint

The sample input contains two data sets. The first data set encodes a network with 2 nodes, power station 0 with pmax(0)=15 and consumer 1 with cmax(1)=20, and 2 power transport lines with lmax(0,1)=20 and lmax(1,0)=10. The maximum value of Con is 15. The second data set encodes the network from figure 1.

Source

Southeastern Europe 2003

题目链接:poj.org/problem?id=1459

题目大意:有n个结点,np个发电站,nc个用户,m条输电路,给出m条输电路及路上最大电量,然后给出np个发电站的位置及最大发电量,nc个用户的位置及最大用电量,求电网中可被消耗的最大电量

题目分析:因为是多源点多汇点,所以我们要设置一个总源点和总汇点,使得总源点0到其他各源点,其他各汇点到总汇点n+1,然后就是普通的最大流问题,用Edmonds_Karp算法求解,把queue<int>q写在while(true)外面比写在里面快了500ms

#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>
using namespace std;
int const INF = 0x3fffffff;
int const MAX = 105;
int c[MAX][MAX];
int f[MAX][MAX];
int a[MAX];
int pre[MAX];
int n, np, nc, m;

int Edmonds_Karp(int s, int t)
{
    int ans = 0;
    queue <int> q;
    while(true)
    {
        memset(a, 0, sizeof(a));
        a[s] = INF;
        q.push(s);
        while(!q.empty())
        {
            int u = q.front();
            q.pop();
            for(int v = 0; v <= n + 1; v++)
            {
                if(!a[v] && c[u][v] > f[u][v])
                {
                    a[v] = min(a[u], c[u][v] - f[u][v]);
                    pre[v] =  u;
                    q.push(v);
                }
            }
        }
        if(a[t] == 0)
            break;
        for(int u = t; u != s; u = pre[u])
        {
            f[pre[u]][u] += a[t];
            f[u][pre[u]] -= a[t];
        }
        ans += a[t];
    }
    return ans;
}

int main()
{
    while(scanf("%d %d %d %d", &n, &np, &nc, &m) != EOF)
    {
        memset(c, 0, sizeof(c));
        memset(f, 0, sizeof(f));
        for(int i = 0 ; i < m; i++)
        {
            int u, v, w;
            scanf(" (%d,%d)%d", &u, &v, &w);
            c[u + 1][v + 1] += w;
        }
        for(int i = 0; i < np; i++)
        {
            int v, w;
            scanf(" (%d)%d", &v, &w);
            c[0][v + 1] += w;
        }
        for(int i = 0; i < nc; i++)
        {
            int u, w;
            scanf(" (%d)%d", &u, &w);
            c[u + 1][n + 1] += w;
        }
        printf("%d\n", Edmonds_Karp(0, n + 1));
    }
}




POJ 1459 Power Network (网络流最大流基础 多源点多汇点 Edmonds_Karp算法)

标签:poj   网络流最大流   edmonds_karp算法   

原文地址:http://blog.csdn.net/tc_to_top/article/details/44117487

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!