码迷,mamicode.com
首页 > Web开发 > 详细

SGU - 302 - BHTML 1.0 (栈的应用)

时间:2015-03-15 13:58:10      阅读:201      评论:0      收藏:0      [点我收藏+]

标签:acm   sgu      字符串   

302. BHTML 1.0

Time limit per test: 0.25 second(s)
Memory limit: 65536 kilobytes
input: standard
output: standard



The hypertext markup language BHTML 1.0 has only two paired tags. They are 技术分享UP技术分享 技术分享/UP技术分享 and 技术分享DOWN技术分享 技术分享/DOWN技术分享. The 技术分享UP技术分享 技术分享/UP技术分享 tag capitalizes all letters inside its body (between an open tag and a close one), and 技术分享DOWN技术分享 技术分享/DOWN技术分享 makes all inside the body letters lowercase. You are given the text consisting of latin letters and tags. Your task is to write the text right as it will be shown in the Bernet Explorer browser window. Tags in the text are arranged correctly, i.e. they form correct bracket sequence. If a letter lays inside several tags, its case is defined by the most inner tag.

Input
The input contains the string S with the text. The length of the string is a natural number not exceeding 1000. Tags are always written in uppercase.

Output
Write to the output text after the processing.

Example(s)
sample input
sample output
Thi<UP>sIs<DOWN>EaSY</DOWN>Pr<UP>O</UP>ble</UP>m 
ThiSISeasyPROBLEm 




Online Contester Team ? 2002 - 2010. All rights reserved.





思路:栈的应用,具体看代码;


AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <stack>
using namespace std;

char str[1005];

int main() {
	while(gets(str) != NULL) {
		stack<int> s;
		int len = strlen(str);
		for(int i = 0; i < len; i++) {
			if(str[i] == '<') {
				if(str[i+1] == 'U') { s.push(1); i += 3; }
				else if(str[i+1] == 'D') { s.push(2); i += 5; }
				else if(str[i+1] == '/') {
					s.pop();
					if(str[i+2] == 'U') i += 4;
					else if(str[i+2] == 'D') i += 6;
				}
			}
			else if(s.empty()) {
				printf("%c", str[i]);
			}
			else if(s.top() == 1) {
				if(str[i] >= 'a' && str[i] <= 'z') printf("%c", str[i]-32);
				else printf("%c", str[i]);
			}
			else if(s.top() == 2) {
				if(str[i] >= 'A' && str[i] <= 'Z') printf("%c", str[i]+32);
				else printf("%c", str[i]);
			}
		}
		printf("\n");
	}
	return 0;
}











SGU - 302 - BHTML 1.0 (栈的应用)

标签:acm   sgu      字符串   

原文地址:http://blog.csdn.net/u014355480/article/details/44275595

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!