码迷,mamicode.com
首页 > 编程语言 > 详细

poj3624 01背包入门 dp+滚动数组

时间:2015-03-15 23:40:32      阅读:202      评论:0      收藏:0      [点我收藏+]

标签:

poj3624 01背包 dp+滚动数组

Charm Bracelet
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 25458   Accepted: 11455

Description

Bessie has gone to the mall‘s jewelry store and spies a charm bracelet. Of course, she‘d like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a ‘desirability‘ factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23
题意:01背包入门题
思路:dp,用二维数组会MLE,由于每个状态只与前一状态有关,故可开滚动数组压缩空间
设放第i个物品的决定(可放可不放)后,已占有容量为j,总价值为dp[i][j],则
dp[i][j]={dp[i-1][j],dp[i-1][w[i]-j]} (w[i]-j>0)
边界控制:
dp[i][j]=0 (i==0||j==0)
dp[i][j]=dp[i-1][j] (w[j]-j>0)
技术分享
/* 背包问题  dp+滚动数组  */
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<ctype.h>

using namespace std;

const int maxn=14100;
const int INF=(1<<28);
int N,M;
int w[maxn],v[maxn];
int dp[2][maxn];
int main()
{
    scanf("%d%d",&N,&M);
    for(int i=1;i<=N;i++) scanf("%d%d",&w[i],&v[i]);
    memset(dp,0,sizeof(dp));
    for(int i=0;i<=N;i++){
        for(int j=0;j<=M;j++){
            if(i==0||j==0) dp[i%2][j]=0;
            else if(j-w[i]<0) dp[i%2][j]=dp[(i+1)%2][j];
            else dp[i%2][j]=max(dp[(i+1)%2][j],dp[(i+1)%2][j-w[i]]+v[i]);
        }
    }
    printf("%d\n",dp[N%2][M]);
    return 0;
}
dp+滚动数组

 

poj3624 01背包入门 dp+滚动数组

标签:

原文地址:http://www.cnblogs.com/--560/p/4340764.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!