码迷,mamicode.com
首页 > 编程语言 > 详细

一种排序

时间:2015-03-16 16:25:22      阅读:163      评论:0      收藏:0      [点我收藏+]

标签:c++   stl   迭代器   

一种排序

时间限制:3000 ms  |  内存限制:65535 KB
难度:3
描述
现在有很多长方形,每一个长方形都有一个编号,这个编号可以重复;还知道这个长方形的宽和长,编号、长、宽都是整数;现在要求按照一下方式排序(默认排序规则都是从小到大);

1.按照编号从小到大排序

2.对于编号相等的长方形,按照长方形的长排序;

3.如果编号和长都相同,按照长方形的宽排序;

4.如果编号、长、宽都相同,就只保留一个长方形用于排序,删除多余的长方形;最后排好序按照指定格式显示所有的长方形;
输入
第一行有一个整数 0<n<10000,表示接下来有n组测试数据;
每一组第一行有一个整数 0<m<1000,表示有m个长方形;
接下来的m行,每一行有三个数 ,第一个数表示长方形的编号,

第二个和第三个数值大的表示长,数值小的表示宽,相等
说明这是一个正方形(数据约定长宽与编号都小于10000);
输出
顺序输出每组数据的所有符合条件的长方形的 编号 长 宽
样例输入
1
8
1 1 1
1 1 1
1 1 2
1 2 1
1 2 2
2 1 1
2 1 2
2 2 1
样例输出
1 1 1
1 2 1
1 2 2
2 1 1
2 2 1

解题思路:

         一开始看到题目的时候我就想到了set来做,因为set能自动帮你完成重复删除且从小到大排列。但是未学过stl,重载的用法。所以在写结构体排序的时候,想不出如何写一个规则使它从左向右按从大到小的顺序排。后来看到了大神的代码焕然大悟的。还有的是以前做过一题不是用结构体的set的题。在输出时是用{a.begin(),a.size()}的,之后也是写这个,结果报错了。原来结构体不能用size了,因为结构体不能计算长度,要用end()才行。
我的代码:
#include <iostream>
#include <algorithm>
#include <set>
using namespace std;
struct S 
{
	int id;
	int h;
	int w;
};
bool operator<(const S& r1,const S& r2)  
{  
	return r1.id<r2.id || r1.id==r2.id && r1.h<r2.h ||r1.id==r2.id&&r1.h==r2.h &&r1.w<r2.w;  
}  
int main()
{
	set<S> a;
	S p;
	int n,m;
	cin >> n;
	while (n--)
	{
		cin >> m;
		for (int i=0;i<m;++i)
		{
			cin >> p.id;
			cin >> p.h >> p.w;
			if (p.h<p.w)
			{
				swap(p.h,p.w);
			}
			a.insert(p);
		}
		set<S>::iterator it;
		for (it=a.begin();it!=a.end();++it)
		{
			cout << it->id << " " << it->h << " " << it->w ;
			cout << endl;
		}
		a.clear();
	}
	return 0;
}
大神地址:http://blog.csdn.net/zcy20121105/article/details/8813138
参考的代码:
#include<iostream>  
#include<set>  
#include<iterator>  
using namespace std;  
struct Rect  
{  
    int num,length,width;  
      
};  
bool operator<(const Rect& r1,const Rect& r2)  
{  
    return r1.num<r2.num || r1.num==r2.num && r1.length<r2.length ||r1.num==r2.num&&r1.length==r2.length &&r1.width<r2.width;  
}  
istream& operator>>(istream& in,Rect& r)  
{  
    in>>r.num;  
    int a,b;  
    cin>>a>>b;  
    r.length=max(a,b);  
    r.width=min(a,b);  
    return in;  
}  
ostream& operator<<(ostream& out,const Rect& r)  
{  
    return out<<r.num<<" "<<r.length<<" "<<r.width;  
}  
int main()  
{  
    int num;  
    cin>>num;  
    while(num--)  
    {  
        set<Rect> rs;  
        Rect r;  
        int n;  
        cin>>n;     
        while(n--)  
        {  
            cin>>r;  
            rs.insert(r);  
        }  
        copy(rs.begin(),rs.end(),ostream_iterator<Rect>(cout,"\n"));  
          
    }  
  
  
}          

一种排序

标签:c++   stl   迭代器   

原文地址:http://blog.csdn.net/zsc2014030403015/article/details/44307523

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!