码迷,mamicode.com
首页 > 编程语言 > 详细

hdoj 1002 A + B Problem II 高精度 java

时间:2015-03-17 12:11:53      阅读:146      评论:0      收藏:0      [点我收藏+]

标签:

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 241933    Accepted Submission(s): 46646


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

 

Sample Input
2 1 2 112233445566778899 998877665544332211
 

 

Sample Output
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 
 
题意:
高精度a+b
 
 
题解
java大法好!
 
import java.util.*;   
import java.io.*;   
import java.math.*;   
  
public class Main{   
    public static void main(String[] args) {   
        Scanner in = new Scanner(System.in);
        int t=in.nextInt();
        for(int i=1;i<=t;i++)
        {
            if(i!=1)
                System.out.println();
            BigInteger a = in.nextBigInteger();
            BigInteger b = in.nextBigInteger();
            System.out.println("Case "+i+":");
            System.out.println(a+" + "+b+" = "+a.add(b));
        }
    }   
}  

 

 
 

hdoj 1002 A + B Problem II 高精度 java

标签:

原文地址:http://www.cnblogs.com/qscqesze/p/4343804.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!