码迷,mamicode.com
首页 > 编程语言 > 详细

hdu 1690 Bus System 最短路 Floyd算法。。INF一定要很大很大。。。数据类型用long long。

时间:2015-03-28 10:09:31      阅读:201      评论:0      收藏:0      [点我收藏+]

标签:hdu1690   bus system   floyd   最短路   

Bus System

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7163    Accepted Submission(s): 1853


Problem Description
Because of the huge population of China, public transportation is very important. Bus is an important transportation method in traditional public transportation system. And it’s still playing an important role even now.
The bus system of City X is quite strange. Unlike other city’s system, the cost of ticket is calculated based on the distance between the two stations. Here is a list which describes the relationship between the distance and the cost.

技术分享


Your neighbor is a person who is a really miser. He asked you to help him to calculate the minimum cost between the two stations he listed. Can you solve this problem for him?
To simplify this problem, you can assume that all the stations are located on a straight line. We use x-coordinates to describe the stations’ positions.
 

Input
The input consists of several test cases. There is a single number above all, the number of cases. There are no more than 20 cases.
Each case contains eight integers on the first line, which are L1, L2, L3, L4, C1, C2, C3, C4, each number is non-negative and not larger than 1,000,000,000. You can also assume that L1<=L2<=L3<=L4.
Two integers, n and m, are given next, representing the number of the stations and questions. Each of the next n lines contains one integer, representing the x-coordinate of the ith station. Each of the next m lines contains two integers, representing the start point and the destination.
In all of the questions, the start point will be different from the destination.
For each case,2<=N<=100,0<=M<=500, each x-coordinate is between -1,000,000,000 and 1,000,000,000, and no two x-coordinates will have the same value.
 

Output
For each question, if the two stations are attainable, print the minimum cost between them. Otherwise, print “Station X and station Y are not attainable.” Use the format in the sample.
 

Sample Input
2 1 2 3 4 1 3 5 7 4 2 1 2 3 4 1 4 4 1 1 2 3 4 1 3 5 7 4 1 1 2 3 10 1 4
 

Sample Output
Case 1: The minimum cost between station 1 and station 4 is 3. The minimum cost between station 4 and station 1 is 3. Case 2: Station 1 and station 4 are not attainable.
 
数据类型用long long。INF设置成千亿最好,,我百亿貌似都WA了。
还有输入输出用%I64d。。。
剩下的就是Floyd干的事了。
代码:
#include <stdio.h>
#include <limits.h>
#define INF 110000000000
typedef long long ll ;
ll graph[110][110] , p[110];
//bool visited[110] ;
ll min(ll a , ll b)
{
	return a>b?b:a ;
}
void floyd(int n)
{
	for(int k = 1 ; k <= n ; ++k)
	{
		for(int i = 1 ; i <= n ; ++i)
		{
			for(int j = 1 ; j <= n ; ++j)
			{
				graph[i][j] = min(graph[i][j],graph[i][k]+graph[k][j]) ;
			}
		}
	}
}

int main()
{
	int t , c = 1;
	scanf("%d",&t) ;
	while(t--)
	{
		ll l1,l2,l3,l4,c1,c2,c3,c4 ;
		scanf("%I64d%I64d%I64d%I64d%I64d%I64d%I64d%I64d",&l1,&l2,&l3,&l4,&c1,&c2,&c3,&c4) ;
		int n , m ;
		scanf("%d%d",&n,&m) ;
		for(int i = 1 ; i <= n ; ++i)
		{
			scanf("%I64d",&p[i]) ;
		}
		for(int i = 1 ; i <= n ; ++i)
		{
			graph[i][i] = 0 ;
			for(int j = 1 ; j < i ; ++j)
			{
				ll dis = p[i]-p[j] ;
				dis = dis>0?dis:-dis ;
				if(dis<=l1)
				{
					graph[i][j] = graph[j][i] = c1 ;
				}
				else if(dis<=l2)
				{
					graph[i][j] = graph[j][i] = c2 ;
				}
				else if(dis<=l3)
				{
					graph[i][j] = graph[j][i] = c3 ;
				}
				else if(dis<=l4)
				{
					graph[i][j] = graph[j][i] = c4 ;
				}
				else
				{
					graph[i][j] = graph[j][i] = INF ;
				}
			}
		}
		floyd(n) ;
		printf("Case %d:\n",c++) ;
		for(int i = 0 ; i < m ; ++i)
		{
			int s , t ;
			scanf("%d%d",&s,&t) ;
			if(graph[s][t] >= INF)
			{
				printf("Station %d and station %d are not attainable.\n",s,t) ;
			}
			else
			{
				printf("The minimum cost between station %d and station %d is %I64d.\n",s,t,graph[s][t]) ;
			}
		}
	}
	return 0 ;
}

与君共勉

hdu 1690 Bus System 最短路 Floyd算法。。INF一定要很大很大。。。数据类型用long long。

标签:hdu1690   bus system   floyd   最短路   

原文地址:http://blog.csdn.net/lionel_d/article/details/44698737

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!