标签:hdu2647 reward 拓扑排序
Reward
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4599 Accepted Submission(s): 1400
Problem Description
Dandelion‘s uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a‘s reward should more than b‘s.Dandelion‘s unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work‘s reward
will be at least 888 , because it‘s a lucky number.
Input
One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)
then m lines ,each line contains two integers a and b ,stands for a‘s reward should be more than b‘s.
Output
For every case ,print the least money dandelion ‘s uncle needs to distribute .If it‘s impossible to fulfill all the works‘ demands ,print -1.
Sample Input
Sample Output
用的前向星储存方式,,用其他的害怕超内存。
储存时注意方向,
否则拓扑排序的顺序就会弄反了。
代码:
#include <stdio.h>
#include <string.h>
#define MAX 10010
int in[MAX] ;
int head[MAX] , t[MAX];
bool visited[MAX] ;
struct Edge{
int to , next ;
}edge[MAX<<1];
int main()
{
int n , m;
while(~scanf("%d%d",&n,&m))
{
memset(head,-1,sizeof(head)) ;
memset(in,0,sizeof(in)) ;
memset(visited,false,sizeof(visited)) ;
int d = 888 , sum = 0 ;
for(int i = 1 ; i <= m ; ++i)
{
int x, y ;
scanf("%d%d",&x,&y) ;
edge[i].to = x ;
edge[i].next = head[y] ;
head[y] = i ;
in[x] ++ ;
}
bool flag = true ;
int i = n ;
while(i>0)
{
int cnt = 0 , index = -1;
for(int j = 1 ; j <= n ; ++j)
{
if(!visited[j] && in[j] == 0)
{
visited[j] = true ;
sum += d ;
t[cnt++] = j ;
--i ;
}
}
if(cnt == 0)
{
flag = false ;
break ;
}
for(int j = 0 ; j < cnt ; ++j)
{
for(int k = head[t[j]] ; k != -1 ; k = edge[k].next)
{
--in[edge[k].to] ;
}
}
++d ;
}
if(flag)
printf("%d\n",sum) ;
else
puts("-1") ;
}
return 0 ;
}
与君共勉hdu 2647 Reward 拓扑排序。
标签:hdu2647 reward 拓扑排序
原文地址:http://blog.csdn.net/lionel_d/article/details/44699365