码迷,mamicode.com
首页 > 编程语言 > 详细

hdu 1548 A strange lift Dijkstra+SPFA算法AC

时间:2015-03-28 15:47:08      阅读:262      评论:0      收藏:0      [点我收藏+]

标签:hdu1548   a strange lift   dijkstra   spfa   最短路   

A strange lift

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13777    Accepted Submission(s): 5254


Problem Description
There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can‘t go up high than N,and can‘t go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you‘ll go up to the 4 th floor,and if you press the button "DOWN", the lift can‘t do it, because it can‘t go down to the -2 th floor,as you know ,the -2 th floor isn‘t exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?
 

Input
The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
A single 0 indicate the end of the input.
 

Output
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can‘t reach floor B,printf "-1".
 

Sample Input
5 1 5 3 3 1 2 5 0
 

Sample Output
3
 简单题。
SPFA代码:
#include <cstdio>
#include <deque>
#define MAX 210 
#define INF 1000000000
using namespace std ;
int graph[MAX][MAX] ;
int t[MAX] ;
bool visited[MAX] ;
int SPFA(int s , int d , int n)
{
	int dis[MAX] , c[MAX];
	for(int i = 1 ; i <= n ; ++i)
	{
		dis[i] = INF ;
		c[i] = 0 ;
		visited[i] = false ;
	}
	dis[s] = 0 ;
	deque<int> que ;
	que.push_front(s) ;
	while(!que.empty())
	{
		int k = que.front() ;
		que.pop_front() ;
		visited[k] = false ;
		c[k]++ ;
		if(c[k]>n)
		{
			return -1 ;
		}
		for(int i = 1 ; i <= n ; ++i)
		{
			if(dis[i]>dis[k]+graph[k][i])
			{
				dis[i] = dis[k]+graph[k][i] ;
				visited[i] = true ;
				if(!que.empty())
				{
					if(que.front()<=dis[i])
						que.push_back(i) ;
					else
						que.push_front(i) ;
				}
				else
				{
					que.push_front(i) ;
				}
			}
		}
	}
	return dis[d] ;
}

int main()
{
	int n , a , b ;
	while(~scanf("%d",&n) && n)
	{
		scanf("%d%d",&a,&b) ;
		for(int i = 1 ; i <= n ; ++i)
		{
			scanf("%d",&t[i]) ;
		}
		for(int i = 0 ; i <= n ; ++i)
		{
			for(int j = 0 ; j <= n ; ++j)
			{
				graph[i][j] = INF ;
			}
		}
		for(int i = 1 ; i <= n ; ++i)
		{
			if(i+t[i]<=n)
			{
				graph[i][i+t[i]] = 1 ;
			}
			if(i-t[i]>0)
			{
				graph[i][i-t[i]] = 1 ;
			}
		}
		if(b<1|b>n)
		{
			puts("-1") ;
			continue ;
		}
		int ans = SPFA(a,b,n) ;
		if(ans >= INF)
			puts("-1") ;
		else
			printf("%d\n",ans) ;
	}
	return 0 ;
}

Dijkstra代码:
#include <stdio.h>
#define MAX 210 
#define INF 1000000000

int graph[MAX][MAX] ;
int t[MAX] , dis[MAX];
bool visited[MAX] ;

void dijkstra(int s , int n)
{
	for(int i = 1 ; i <= n ; ++i)
	{
		dis[i] = graph[s][i] ;
		visited[i] = false ;
	}
	dis[s] = 0 ;			//忘了写这行代码。。让我wrong成SB了 
	visited[s] = true ;
	for(int i = 1 ; i < n ; ++i)
	{
		int index = -1 , min = INF;
		for(int j = 1 ; j <= n ; ++j)
		{
			if(!visited[j] && dis[j]<min)
			{
				index = j ;
				min = dis[j] ;
			}
		}
		if(index == -1)
		{
			return ;
		}
		visited[index] = true ;
		for(int j = 1 ; j <= n ; ++j)
		{
			if(!visited[j] && dis[j]>dis[index]+graph[index][j])
			{
				dis[j] = dis[index]+graph[index][j] ;
			}
		}
	}
}

int main()
{
	int n , a , b ;
	while(~scanf("%d",&n) && n)
	{
		scanf("%d%d",&a,&b) ;
		for(int i = 1 ; i <= n ; ++i)
		{
			scanf("%d",&t[i]) ;
		}
		for(int i = 0 ; i <= n ; ++i)
		{
			for(int j = 0 ; j <= n ; ++j)
			{
				graph[i][j] = INF ;
			}
		}
		for(int i = 1 ; i <= n ; ++i)
		{
			if(i+t[i]<=n)
			{
				graph[i][i+t[i]] = 1 ;
			}
			if(i-t[i]>0)
			{
				graph[i][i-t[i]] = 1 ;
			}
		}
		if(b<1|b>n)
		{
			puts("-1") ;
			continue ;
		}
		dijkstra(a,n) ;
		if(dis[b] >= INF)
			puts("-1") ;
		else
			printf("%d\n",dis[b]) ;
	}
	return 0 ;
}

与君共勉

hdu 1548 A strange lift Dijkstra+SPFA算法AC

标签:hdu1548   a strange lift   dijkstra   spfa   最短路   

原文地址:http://blog.csdn.net/lionel_d/article/details/44701901

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!